Jump to content

Shark Jack kills my computer's Internet connection in Arming Mode


Recommended Posts

I just received my Shark Jack and upgraded the firmware to 1.1.0.  When I put the Shark Jack in Arming Mode and plug it into my Macbook Pro computer, it kills my computer's Internet connection.  The minute I unplug it, the Internet connection comes back.

Any help on this????

Link to post
Share on other sites

Probably your Computer takes the Shark Jack as Default Gateway. Difficult to tell with so few info. Could you post the output of the following commands with the Shark attached and also not attached?

ip r g 8.8.8.8
ip a

(I hope those commands run under Mac OS too... :sigh:)

Link to post
Share on other sites

LOL!  I had to do brew install iproute2mac so I can get the ip command on my MacOS.

Yep, when the Shark Jack is in Arming Mode and plugged into my computer, the default gateway is 172.16.24.1 and when it's not plugged in my default gateway is my firewall's inside interface 192.168.0.1.

http://sw-techgroup.net/images/ip-command-sj.png

http://sw-techgroup.net/images/ip-command-no-sj.png

 

 

Link to post
Share on other sites
  • 2 months later...

I believe the issue the OP is having is that there are 2 default gateways. I get a similar issue on any computer with 2 network connections, when both connections have a DHCP server configured. The WiFi Pineapple Nano comes to mind, for example, when I plug in the USB connection to my laptop, my Internet goes down.

 

The easiest solution is to configure the SharkJack interface to use a Static IP, and don’t specify a Default Gateway. In most cases, you can leave the DNS server blank also.

Link to post
Share on other sites

The issue here is that dnsmasq on the Shark Jack sends option 3 indicating that the dnsmasq host (the Shark Jack) is the default router.

This is dnsmasq's default behavior, but it can be changed by adding the following line to the configuration file and then restarting dnsmasq.

dhcp-option=3

Frankly, I think this should be the default behavior in arming mode.

The dnsmasq configuration file on my system is at /var/etc/dnsmasq.conf.cfg<numbers-i-don't-recognize>.

A simple procedure:

  1. Note the dnsmasq running parameters with `ps -w | grep dnsmasq`
  2. Edit the config file (the one after the `-C` argument)
  3. Kill the dnsmasq process: `killall dnsmasq`
  4. The process should start back up in a moment
  5. Unplug/replace the Shark Jack so that the link bounces on your PC. You'll drop the bogus gateway and it won't be re-installed.

Unfortunately, this only works for a single boot of the Shark Jack. Making it persistent eludes me right now.

Link to post
Share on other sites

Okay, it turns out that the /var/etc/dnsmasq.conf<instance> file (which is generated on boot) refers to /etc/dnsmasq.conf. So, putting the previously mentioned option in /etc/dnsmasq.conf makes it persistent. ...But that may not be very useful, depending on what sort of payloads you intend to run.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...