Jump to content
p28312

2.7 and SD Card not working

Recommended Posts

After I upgraded to 2.7, did a hard reset.  The SD Card was not being recognized - format option spun forever.  Used Windows to remove the two volumes, and then was able to format it in the portal..but it is still not being recognized.  Not sure where to go from here.

Thanks

Share this post


Link to post
Share on other sites

I've run into this as  well... I haven't solved it quite yet but this is what I've done so far:

This can be a real problem to mount or get working. You can find loads of interesting error messages in dmesg but none of them will make much sense. The recommendation is to format the SD Card in the webinterface. Under Advanced you can click on USB & Storage and select Format SD Card. That may very well not work.

The SD Card has two partions

  • data partition
  • swap partition

Commands you will use a lot

  fdisk -l
  dmesg

The solution [1] here at least formats your sd card in the right way. You may need to perform a few of these steps from another linux PC though - every time I tried the mkfs.ext4 /dev/sda1 on the pineapple the scsi bus would reboot and it would tell me /dev/sda1 doesn't exist.

Tools to wipe from sdcard.org

SD Memory Card Formatter 5.0.1 for SD/SDHC/SDXC

complete wipe and gui format

   Completely wipe SD card with dd if=/dev/zero of=/dev/sdcard/sd bs=4096
   Eject SD card from WiFi Pineapple NANO
   Power off WiFi Pineapple NANO
   Insert SD card into WiFi Pineapple NANO
   Power on WiFi Pineapple NANO
   Use the webinterface to format the SD card (this may take a while). Alternatively, use a linux distro to format the SD card ext4.
   The card should mount automatically. If it does not, reboot the WiFi Pineapple NANO.

hand formatting

Format SD Card

   cat /pineapple/modules/Advanced/formatSD/fdisk_options | fdisk /dev/sda
   mkfs.ext4 /dev/sda1
   mkfs.ext4 /dev/sda2
   mkswap /dev/sda2
   mkdir /sd

change /etc/config/fstab to:

   config global
   	option anon_swap '0'
   	option anon_mount '0'
   	option auto_swap '1'
   	option auto_mount '1'
   	option delay_root '5'
   	option check_fs '0'
   config mount
   	option target '/sd'
   	option device '/dev/sda1'
   	option fstype 'auto'
   	option options 'rw,sync'
   	option enabled '1'
   config 'swap'
           option device '/dev/sda2'
           option enabled '1'

Reboot and the SD Card should be mounted.

(from https://wiki.edgarbv.com/index.php/Wifi_Pineapple_Nano#SD_Card)

I am running into dmesg showing the sdcard being remounted a lot - to sda sdb sdc sdd etc etc and some errors showing the sdcard has errors (it doesn't according to fsck, but oh well) like
print_req_error: I/O error, dev sda, sector 136
Buffer I/O error on dev sda, logical block 17, async page read
ath: phy1: Short RX data len, dropping (dlen: 5)
etc.

I am now trying the SD Card Formatter and doing a full overwrite format takes a long long time. I have heard that the nano can be very finicky with SD cards so if this doesn't work I am just going to buy a few 32 / 64 / 128 gb ones and try them one after another.

Keep me posted how you're doing, I am very curious!

Share this post


Link to post
Share on other sites

i am having the same issue, since upgrading the firmware the SD card is vanishing, ended up formatting and reinstalling some modules but after about 30 minutes it had vanished again, tried a couple of other sd cards, and a brand new one, all behaving the same way.  after a reboot of the nano it seems okay then things start misbehaving

Share this post


Link to post
Share on other sites

Same issues!

Format my sd card... And everything is fine, it's recognised and I'm able to install modules to it. I then restart the nano, poof sd card is not longer mounted.

Share this post


Link to post
Share on other sites

Hi,

Thanks for reporting issues with the SD Card mounting. I've spent some time trying to reproduce but can't, so I've gone and got a variety of SD Cards to try and isolate this issue with. Log output from "dmesg" and "logread" is appreciated as it helps trying to diagnose these issues.

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

I was having the same issues until I consoled into my pineapple and just did the formatting and partitioning by hand. This might help

 

Share this post


Link to post
Share on other sites

@Foxtrot I ran into this issue as well with v 2.7.0

What caused it for me was shutting down the NANO via the web portal icon (Log off, Reboot, Shutdown)

When I went to power the NANO back up later, the SD card was empty/unmounted.

Edited by Idk_Man

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...