Jump to content

Nano resets often - initial setup needed


Recommended Posts

- Are you downloading the modules to an SD card or internally? (I've only saved to the SD card and haven't had any issues)

- Are you using a proper 2A power source with the USB y-cable?

- Are you running the latest software version? (2.6.2 as of writing this)

- Is your reset button (On the bottom of the NANO) jammed inwards or possibly loose?

- Have you tried a firmware reset/factory reset yet to see if the problem remains?

- How long does your NANO stay powered up before it resets itself? Will it reset on it's own sitting plugged into power, or does it only reset once you connect to it via the website or SSH?

- What modules do you have installed?

Link to comment
Share on other sites

Thank you for your answer.  First I want to clear a slight misunderstanding.  The device does not reset while running,  it resets to "setup" after switching it off (with ssh to it and doing halt to properly umount the sd card) and back on again.  When it stars again I need to perform the whole initial setup procedure again.

To answer your questions:

- I'm downloading the modules only to sd card as I found it rather useful when the device resets itself to defaults,  the modules on sd card remain

- I was using 2A power during the flashing process; I was unaware that during run you need to still connected to 2A source.  I power it via usb y-cable that was shipped with the nano device.  From the videos I never saw the nano device connected to external power.

- Yes, I'm running the latest, greatest 2.6.2

- The reset button looks firmly in place and works everytime after reset/reboot (user is required to press it during the setup), so that should not be an issue

- Yes, I did try that out when I bricked the device when I tried to update to newest nginx.  I did full factory reset with proper BIOS.

- Well the device runs for hours without a glitch only with combination tmux and hcxdumptool I have experienced freezing.  After issuing a halt command the device resets itself and I need perform the initial setup again.

The list of modules (all of the on SD card):






Link to comment
Share on other sites

That's weird. I don't have a whole lot of experience with ssh'ing into it yet besides the basics so I won't be much help there unfortunately.

- Does it still reset to the setup screen if you use the NANO through the website? ( Just curious.

- Shooting in the dark here, but have you tried to reformat the SD card (perhaps it became corrupted. I've had that happen to me and the NANO didn't like that) or can you try using a different SD card - making sure to format it first.

- I'm not 100% sure if you need to use 2A while the NANO is running, but it couldn't hurt for troubleshooting purposes. Provide the NANO it's full power requirements to eliminate it being a power supply issue.

- That's good that you're using version 2.6.2

- I think we can eliminate your reset button being bad so that's good.

- Have you preformed a firmware reset in conjunction with a factory reset on your NANO yet? https://docs.hak5.org/hc/en-us/articles/360010471774-Firmware-Recovery Couldn't hurt to start from scratch and it only takes about 5-10 minutes.



After playing around with my NANO, it's now doing the same rest loop as yours @jackTheSignal (I don't have any modules loaded on the SD card - already formatted it via Windows)

How I got my NANO to do the reset loop (For the Hak5 admins @Darren Kitchen @Foxtrot @Sebkinne wondering how unintentionally fucking up the NANO's) I was on a different thread trying to help another user through a firmware reset, and after I performed it myself on my NANO, it started doing the same reset loop described as above.

Luckily, I back tracked and figured out the root cause and now my NANO's working fine with no reset loop. So hopefully @jackTheSignal this will work for you as well.

Perform a firmware reset following the provided instructions here (https://docs.hak5.org/hc/en-us/articles/360010471774-Firmware-Recovery) **HOWEVER** don't click on the link provided for the NANO Recovery Image. For whatever reason (perhaps it's an old/outdated/incompatible/corrupted link?) when I uploaded this file into my NANO, it worked at first but the initial setup screen was slightly different that what I was used to seeing.

What I saw:

1. When I pressed the reset button to disable the WiFi antennas to complete the initial setup, the blue LED wouldn't shut off like it normally does.

2. The filter options for Client and SSID were different than what I was used to seeing. It didn't have any check mark boxes, but rather a buttons to change them from allow or deny.

3. The web portals "Dashboard" screen "Bulletins" button was different as well.

(After I completed the setup, within the minuet the NANO started doing the perpetual reset loop.)


I followed the same firmware reset instructions provided above but I used this link instead for my firmware image (https://www.wifipineapple.com/downloads) (I used the 2.6.2 download) and loaded that into the NANO. No issues now. (Make sure to give your NANO about 5 full minutes to fully update after you upload the new firmware)

Link to comment
Share on other sites

@jackTheSignal I also found that my NANO will do the auto-loop issue as stated above whenever I use my external USB hub. If I plug in the y-cable adaptor directly to my computers USB ports, the issue goes away. Double check your USB connections. Wiggle them around/try a different computer.

Link to comment
Share on other sites

Be sure that the WiFi Pineapple NANO is provided the requisite 9W of power. See the power consideration article at https://docs.hak5.org/hc/en-us/articles/360010471754-Power-Considerations

Essentially, a typical 2A USB source will be adequate - but if an unpowered hub is used with other accessories attached, you'll experience reboots and/or boot loops if the device isn't adequately powered. 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...