Jump to content

Tools not installing on bash bunny and whenever i ssh into it the udisk folder is empty


Recommended Posts

ok so i feel really stupid. My bash bunny works fine with most payloads, however i ran into several problems. When i first tried to install new firmware the updater app just didnt do anything and i forgot to eject it once so it created a dirty bit too. so i decided to factory reset it and also ran reformat udisk in the ssh terminal.

This seemed to fix the firmware problem and i have now updated to 1.6. however when i try to install tools by putting .deb files into the tools folder, ejecting and reconnecting, the tools folder is now empty. I was not sure if this was normal or not because i thought the files might be somewhere else. but they dont seem to because the tools folder in the udisk is definitely empty (i managed to make it not be empty by running mount -o sync /dev/nandf /root/udisk and then i check the tools folder and it is empty).

one of the tools i tried to install was responder and i tried running responder by just typing in the word in the command line and it said -bash: responder: command not found . I have run out of options and dont know any other way to install tools. 

Link to post
Share on other sites

yes, it is normal that they are gone

just ssh into the bunny, then do this:

cd /

cd tools

cd responder

and now you are in the responder directory (works only if you've installed it obviously)

to list all the tools you've installed:

cd /

cd tools

ls

You can't just run "responder", this isn't even a command, and you are not in the right directory when you login. You have to cd to responder first (the commands I showed you above do that). When you SSH into the bunny, it is just like a normal linux terminal, you can do anything you could do in linux. That is some basic stuff you should know (I don't blame you or anything, it just makes it easier to work with the bunny 🙂)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...