Jump to content

Using ethernet to provide shared network?


Sphenix

Recommended Posts

So I've re-arranged my current setup to the following;
Home Router -- PC -- WiFi Pineapple  -- Raspberry Pi

Router/PC is over Ethernet, then I'm sharing the connection through the USB-ETH, now I'm wanting to use the vacant Ethernet on the pineapple to link the Raspberry pi in.

I assume it's very well possible, but I've tried forcing gateway, subnet, and assigning a static ip with a config to get the pi online. All I receive is no DHCPOFFERS, and on static I just get host unresponsive on any ping I try. Got flashing lights at both ends of the cord, no leases are created, etc.

Setting gateway on 172.16.42.1 and subnet to 255.255.255.0

Any help is appreciated ūüėä

Link to comment
Share on other sites

Little update and outputs, swapped gateway to 172.16.42.42 instead of .1, and these are my outputs;

TCPDump on eth0

10:31:09.952820 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from b8:27:xx:xx:xx:xx (oui Unknown), length 300
10:31:15.944132 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from b8:27:xx:xx:xx:xx (oui Unknown), length 300
10:31:21.831937 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from b8:27:xx:xx:xx:xx (oui Unknown), length 300
10:31:34.112855 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from b8:27:xx:xx:xx:xx (oui Unknown), length 300
10:31:49.388779 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from b8:27:xx:xx:xx:xx (oui Unknown), length 300
10:31:59.042287 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from b8:27:xx:xx:xx:xx (oui Unknown), length 300

And logqueries output
 

daemon.notice netifd: Network device 'eth0' link is up
daemon.notice netifd: Interface 'wan' has link connectivity
daemon.notice netifd: Interface 'wan' is setting up now
daemon.notice netifd: Interface 'wan6' has link connectivity
daemon.notice netifd: Interface 'wan6' is setting up now
kern.info kernel: [  190.294171] eth0: link up (1000Mbps/Full duplex)
daemon.notice netifd: Interface 'wan6' is now up
daemon.notice netifd: wan (1904): udhcpc: started, v1.30.1
user.notice firewall: Reloading firewall due to ifup of wan6 (eth0)
daemon.notice netifd: wan (1904): udhcpc: sending discover
daemon.notice netifd: wan (1904): udhcpc: sending discover
daemon.notice netifd: wan (1904): udhcpc: sending discover
kern.info kernel: [  253.338946] device eth0 left promiscuous mode

Output from RPI ends with no DHCPOffers received. Feel like I'm totally overlooking something.

 

Link to comment
Share on other sites

Have you tried connecting a regular computer to the WAN side of the Pineapple to confirm its giving out DHCP addresses?  Also try that and set a static IP on the computer and confirm you can connect and route out of the Pineapple.

Also, try plugging your Pi into a regular router and confirm it's able to get a DHCP address.   This will at least let you determine if one of the devices isn't functioning as it should with respect to DHCP (client or server).

Link to comment
Share on other sites

21 hours ago, stusmith said:

Have you tried connecting a regular computer to the WAN side of the Pineapple to confirm its giving out DHCP addresses?  Also try that and set a static IP on the computer and confirm you can connect and route out of the Pineapple.

Also, try plugging your Pi into a regular router and confirm it's able to get a DHCP address.   This will at least let you determine if one of the devices isn't functioning as it should with respect to DHCP (client or server).

I've noticed I was on an older software version so I've updated my tetra firmware (with openwrt 19.07) -

The pi does obtain over ethernet on my home router, but plugging ethernet from pineapple to a laptop I get the same results - only thing it's getting right is the subnet.
Tried setting static and forcing the same info on the laptop device properties, ipconfig then showed the right gateway but still a 169 address. Logquery printing same "sending discover" messages then cuts.

I started to suspect my changes in the /network config file were probably to blame but I've got it back to a fresh start, same outputs

Link to comment
Share on other sites

To do what you are wanting there are some setting that will need changed through the tetra terminal.  Just setting static IP on the pi will do no good as the tetra needs set to share it WAN connection over the RJ45 port.  This is not a typical configuration for the tetra as it would be mostly used for WAN connections then using the wireless interface for connection clients to the AP.  Do you have a pre model 3 pi? If you do have a pi 3, why not use the wireless interface on the pi for connection? 

Link to comment
Share on other sites

7 minutes ago, Cap_Sig said:

To do what you are wanting there are some setting that will need changed through the tetra terminal.  Just setting static IP on the pi will do no good as the tetra needs set to share it WAN connection over the RJ45 port.  This is not a typical configuration for the tetra as it would be mostly used for WAN connections then using the wireless interface for connection clients to the AP.  Do you have a pre model 3 pi? If you do have a pi 3, why not use the wireless interface on the pi for connection? 

Yes - The tcpdump and syslog dhcp outputs are from the pinapple. I have been working with the /etc/config/network wan configuration to set the static information for the pi on WAN for eth0.

I do have a pi 3 with WiFi, but for the streaming I'm trying to work with, I need a much more stable connection than the WiFi. When plugged directly into my home router, it handles a very stable connection - but sharing over wifi I get a lot of frame stutter and input delay, so I'm trying to figure this out so I can provide it in a separate area of my house where the pineapple is.

I guess if there's no good way to do it I could find a switch lying around and plug the ethernet there.

Link to comment
Share on other sites

20 minutes ago, Sphenix said:

I have been working with the /etc/config/network wan configuration to set the static information for the pi on WAN for eth0.

post what your edited config is for this.

20 minutes ago, Sphenix said:

I guess if there's no good way to do it I could find a switch lying around and plug the ethernet there.

This would be the easiest/fastest way, but understand wanting to do something just because you can.

Link to comment
Share on other sites

9 hours ago, Cap_Sig said:

post what your edited config is for this.

This would be the easiest/fastest way, but understand wanting to do something just because you can.

Well it was my understanding from here; https://openwrt.org/docs/guide-user/base-system/basic-networking

that the only thing holding eth0 back from providing lan is where the ifname was stated. I assumed moving it up to LAN and swapping off of static to dhcp would allow it to be set - but I've just earned myself a factory reset doing that, wondering if I should be working in the dhcp config aswell for a second interface, then setting eth0 and dhcp for that interface?

Link to comment
Share on other sites

DHCP settings will need adjusted as well if you want the port to issue an IP to the pi. 

I am only speculating but iptables will most likely need some work done as well.  This is to allow proper routing and possible firewall exceptions.  But I'm by no means an OpenWRT expert. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...