Jump to content
exit_n0de

SD card problems since v2.5.x

Recommended Posts

Hey folks!

Since I have updated to the version 2.5.0(now i'm on 2.6.2), I've come across with some problems.

 

1. Problem:

The Pineapple didn't (always) mount the sd card when I boot it up.

So, I've tested several things with 3 types of sd cards from different vendors with different memory size(4GB,8GB,64GB). I've formatted the sd's in the first pass under Windows, insert it in the pineapple and reboot. Didn't work. The I formatted them with gparted to ext4, tested it. Didn't work. Then I've done the same thing again and after this I formatted it under the Advanced tab in the Pinapple WebUI. Also, didn't work.

I also opened the Pineapple Nano, looked at the soldering point under a microscope if there are some cold solder joints.

When the Pineapple is up and running and I eject the sd card and insert it again, it works normally.

I also tried to add "options UUID" to the fstab conf, but this also didn't work.

My fstab config(default):
 

config global
    option anon_swap '0'
    option anon_mount '0'
    option auto_swap '1'
    option auto_mount '1'
    option delay_root '5'
    option check_fs '0'

config mount
    option target '/sd'
    option device '/dev/sdcard/sd1'
    option fstype 'auto'
    option options 'rw,sync'
    option enabled '1'

 

2. Problem:

I can't change the Pool Location under PineAP to a directory I've created on /sd, because otherwise under the Dashboard the number of collected SSID's disappears.

https://imgur.com/a/TnpC2VZ

I also can't add my own SSID's to the Pool when the Pool Location is set to the path on the sd card. I've tested to change the default path from /etc/pineapple to other internal random paths. It works as it should. I also tested to move the ssid_file with some SSID's from /etc/pineapple to /sd/ssid_pool (my created path on the sd card). The number of collected SSID's is still not shown on the Dashboard and I'm also unable to add my own SSID's nor when I'm enable the PineAP it didn't collect any SSID's to the pool

https://imgur.com/a/Ec7a9uN

 

The only solution is to flash the firmware back to 2.4.2 or install and save everything on the internal memory... but I won't. For obvious reasons 😄

 

The funny thing is, that a fellow student have the Tetra and for him the v2.6.2 works fine, without any problems. So I think it is a problem with the rewritten PineAP Code only for the Nano OR I am to stupid to get the fcking sd to work xD

So, who ever rewritten the PineAP Code: plz, do it again :'D

I hope you can help me ❤️

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...