Jump to content

Connection to Internet issues


Recommended Posts


I've acquired WiFi Pinapple Nano and started to set it up. Everything went fine following the video. I'm setting it up on the latest Kali Linux.

But after running the wp6 script, I try to get modules or load bulletins from Hak5, but cannot get an internet connection from the Nano.

I've tried some tips that were on the forum, but nothing seem to be helping, so I need some advice.

I got my Nano at ip and can access the web interface just fine.

My Internet is coming from wlan0 interface, with ip on the 172.168.1.x network.

This is what is shown on the network tab of the web interface. 


I'm kind of lost here, some guidance is appreciated and thanks in advance.


Link to comment
Share on other sites

You have an issue with the connection sharing.  Websites loading on your Kali machine has nothing to do with your nano getting WAN access.  It just shows that you have a WAN connection that is working.

Your nano is showing no default gateway.  You might have selected the wrong interface when running the wp6 script.

Take a look at this page for more help on setting up different connection types with the nano: https://wiki.wifipineapple.com/#!connectivity.md

Link to comment
Share on other sites

  • 2 months later...

This is just to also add in another factor as to why ICS may not work !


Recently,  I went to upgrade both my Nano and Tetra. 

Starting with the Nano, I got it to update via the manual way but could not get Internet Connection Sharing working from my Windows 10 Pro Laptop.

I followed the ICS instructions to the T and it did not work for me.  Tried the slight mod as posted here to no avail.

I even changed the Registry key for the Shared Access to force it to use as suggested.

The Registry Key is:  "Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Parameters"

Changed the "ScopeAddress" and the "ScopeAddressBackup"  to the suggested  When I turned on ICS, it forced the IP to be correct. 🙂

[ Side Note, Yes, you can force your system to use a different default IP address than the standard Windows ICS range. Just change the Registry keys as shown above]


However, I still could not get the ICS working even telling Windows to force the Ip to what is required.

More digging turned up the problem.

While Windows Firewall didn't care if the ICS was turned on or off, the AntiVirus software DID !

I had to go into the AV settings for the AV Firewall and tell it to "Allow Internet Connection Sharing".  Once I did that, it all worked perfectly.


I wanted to add this information to this post for those still not able to get ICS working.  Sometimes it's not ICS but another Software Firewall blocking it.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...