Jump to content

Bash Bunny Switch not working & won't upgrade or restore


Recommended Posts

Brand new bash bunny. Firmware 1.3_267

Connected to my laptop, it powers up, and gets to state where LED is flashing blue slowly.

I can successfully connect to the serial console, and see the mass storage device in Windows or Linux.

Problem 1: Regardless of which switch position, it wont run any payload. I tried setting \payloads\switch1\payload.txt & \payloads\switch2\payload.txt to:

LED R 100
source bunny_helpers.sh

I unplug it, set switch to Position 1, plug it into a windows laptop, but nothing happens. Same for position 2. And nothing happens in arming mode either.

Problem 2: Firmware wont update

I downloaded the latest ch_fw_1.6_305.tar.gz from https://downloads.hak5.org/bunny and copied it to the root of the filesystem (as seen by Windows).

Check the sha256sum is correct on the bashbunny's version of the tar.gz file.

Safely ejected the Bash Bunny

Connected it to the laptop again, and waited.

It just follows the normal boot process and starts flashing blue slowly within a few seconds of connecting. there is no flashing red to indicate it is applying the update.


Problem 3: Wont restore from recovery partition

I tried the process mentioned by @Darren Kitchen to create 3 failed boots and force it to do a recovery. But it also doesn't work. I plugged it into a USB power bank (not a computer), waited until green light went off (after ~2sec), disconnected, repeated 3 times, then plugged it in and waited. there was no flashing red/police light. It just booted normally.



A) Is there a way to debug the switch position from within the serial console?

B) Is there a way to manually run the firmware update from inside the serial console?


Any help appreciated.


Link to comment
Share on other sites

  • 2 years later...

Same problem.

Mine is new (bought 2 years ago and never used) Plugged it for first time today. Did the update process but same issue as above.

1. Green light goes on, then blue blinking updated never happen

2. Tried the updater 1.1 and tried to do the firmware recovery by unplugging 3 times when the green light goes out

All that happens when you plug it back in is Green Light then Blue blinking.

Version onboard is 1.3.67 I just wanted to update it to latest.
Not tried the switches as it only has default payload.


Link to comment
Share on other sites

To see if the switch itself is behaving correctly, you can try this

Put the Bunny in arming mode

Serial into the Bunny using MiniCom or PuTTy (or whatever)

cat /sys/class/gpio_sw/PA8/data
if the result is 0 then switch1 is used

cat /sys/class/gpio_sw/PL4/data
if the result is 0 then switch2 is used

cat /sys/class/gpio_sw/PL3/data
if the result is 0 then switch3 (arming mode) is used

It's possible to flip the switch while the Bunny is running in arming mode in order to try all positions

  • Thanks 1
  • Upvote 1
Link to comment
Share on other sites

Good that you seem to have gotten it sorted

The test above can of course also be scripted. Run the script in each switch position and the "zero" should do a House of Pain... Jump around!


echo ""
echo "Testing Bunny switches"
echo ""
echo ""
echo "The output that returns a 0 (zero) represents the current switch"
echo ""
echo "Testing Switch1"
cat /sys/class/gpio_sw/PA8/data
echo "Testing Switch2"
cat /sys/class/gpio_sw/PL4/data
echo "Testing Switch3 (arming mode)"
cat /sys/class/gpio_sw/PL3/data
echo ""


Edited by dark_pyrro
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...