Jump to content

SD card needs formatting (not formatting)


Recommended Posts

I just currently purchased the Hak5 Essentials Kit and currently setting up the pineapple nano. I have connected to wifi and able to see the modules available, but when I download one a prompt says, 

This module is developed by sebkinne, a third-party developer.

Generally, module support can be found at forums.hak5.org. You do not have enough free space to install this module. Please insert an SD card and ensure that it is formatted correctly.

I tried to reformat to ext /fat in disk utility, as I'm on a macpro. 


I am also running Virtual box with Backtrack5 and trying to make everything connect cohesively. 

Me being new to security and linux- doing this alone has proved to be somewhat difficult. 


I have saved the fstab- (which said downloaded successfully)

also I clocked format card from the advanced options tab on the GUI and nothing happens. 



I apologize if there is a significant lack of information but I am eager to dial this in and learn what I need to use this awesome tool. Please advise and thanks for taking the time!

Link to comment
Share on other sites

This may be different on mac but log into the wifi pineapple via ip address (as you normally would) then navigate to advanced . It will have two gears spinning as an icon , once you click on the advanced tab navigate all the way to the top where it says USB . There... you will see an arrow. Click on that arrow and it will have an option to format the SDcard 

Hope this helps you 🙂

Link to comment
Share on other sites

Haha no worries. Also while im the terminal im Backtrack5, I also tried to download the wpa6.sh and it looked like it worked except for the last line in the prompt that said something about SSH unavailable? 

I created a mew admin user through the terminal and I can’t login to root anymore. When i load up backtrack from virtualbox, this is what i see. 


the panel encountered a problem while loading “OAFIID:GNOME_FASTUserSwitchApplet.”

do you want to delete the applett from your configuration? 


End error message

Do you think that I corrupted my Backtrack5? I don’t know if this has anything to do with this issue, or if root dissapears from login after another admin is created. Appreciate the help


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...