Jump to content
Johann

E-Mail Report / ssmtp

Recommended Posts

I have a pineapple tetra with firmware 2.6.2. I tried to configure e-mail reports but it doesn't work.

Hence i tried to debug the e-mail reportin. In /pineapple/modules/Reporting/files/reporting i changed in line 30 the output redirection to a file. The logged error i got  is:

/pineapple/modules/Reporting/files/reporting: line 30: ssmtp: command not found

I tried to find the ssmtp command, but i couldn´t find it on my pineapple.

Share this post


Link to post
Share on other sites
After searching for a while, I found the solution. ssmtp wasn't installed on my pineapple. After installing and configuratiing ssmtp it works.

I'm a little surprised that ssmtp is not installed by default.

Share this post


Link to post
Share on other sites

I was a little bit to fast - E-Mail works but no attachments because uuencode was missing.

I downgraded my pineapple to 2.5.4 - and now everything works fine. It seams that 2.6.x is a little bit buggy 😞

Share this post


Link to post
Share on other sites
On 1/31/2020 at 9:47 AM, Natur3kid said:

Any News on this?

@Foxtrot

Sorry for my delayed response.

A 2.6.3 release will be launched soon (no exact ETA.) to address this.

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...