Jump to content
TheSentinel

Issue with SSH Terminal to Packet Squirrel

Recommended Posts

Hi all,

first of great work !

I installed Hak5 Cloud C2 2.1.0 - Community Edition on a Ubuntu 18.04 running on MS Azure following this guide below.  

So far so good everything worked fine. 🙂

I connected right away my Packet Squirrel (Version 3.2) successfully. The device is shown as online.

image.thumb.png.8c41002d8f2b087dd7305524e9e5202e.png

When I click on "Terminal" followed by a click in "Start SSH Connection" this happens and I cant get it work!

Does anyone of you has an idea ?!? I am lost ...

 

image.png

Share this post


Link to post
Share on other sites

Hi @TheSentinel could you verify that you have port 2022 open on your machine?

P.S. I'll try to replicate this on my end as well. Just a heads up however, there's a new update for C2 which is V2.1.1 that you can update to by simply logging into your C2 cloud.

Edited by Void-Byte

Share this post


Link to post
Share on other sites
2 hours ago, TheSentinel said:

Hi port 8022 TCP is open inbound to the ubuntu system running C2.That cant the the issue ... 

 

Hi @TheSentinel you stated that port 8022 was open. Did you perhaps mean 2022? The following ports are required for C2 Cloud (unless you changed).

Ports: 80,22,443,2022 (when utilizing https).

 

Edited by Void-Byte

Share this post


Link to post
Share on other sites

Having the same problem.

On my Cloud C2 server I can see the reverse SSH session arriving and in TCP ESTABLISHED state.

When I connect to the websocket via CLI, I get an error "device not connected" from the WebSocket, which the UI does not seem to handle gracefully (the API however DOES return the device is indeed connected in the API the browser calls before doing the WebSocket).

Share this post


Link to post
Share on other sites

Having exact same issue when trying to SSH to Lan Turtle from C2, worked before upgrade to latest version of C2... appears to be bug in new c2 software update

Share this post


Link to post
Share on other sites

Hello,

We have confirmed an issue with the Web Terminal on the Cloud C2, and it's been fixed pending release shortly.

I would expect it to be released on Monday.

Share this post


Link to post
Share on other sites

I'm still having an issue using the C2 Terminal to connect to my SharkJack, even after the C2 upgrade. The Shark shows up as online in C2, it uploads Loot, but the terminal connection never connects. I can SSH into the Shark from a local computer, so I know that the SSHD is running. I have tested with several Signal Owls and I am able to connect to them from C2 using Terminal, so I don't think the problem is on the C2 end. All devices are running latest available firmware, and C2 is version 2.1.2.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...