Jump to content

Copy tools to Bash Bunny


Gunky
 Share

Recommended Posts

I'm trying to copy tools on to the BB in arming mode and anything I want to copy seems to be written successfully however as soon as I remove and reinsert the drive the files are gone.

I'll start with the two obvious things, yes I eject it properly to ensure the files are written and there is no AV running.

I have tried a factory reset then upgrading to the latest firmware then udisk reformat but this has not helped. I have tried copying from Debian and Windows. If I copy to any other locaiton it works just fine.

Link to comment
Share on other sites

If you copy the tools, plug the BB out and in, then the tools are gone. That's completely normal. Next step is to check in terminal if the tools are really gone.

If you don't know how to do that: Download PuTTY and plug the BB in while it's in ATTACKMODE RNDIS_ETHERNET. Then in PuTTY select SSH and as ip-adress select 172.16.64.1, and as port select 22. 

Login is username "root" and password "hak5bunny". Be sure to change the password, i'm not gonna explain that. you can look that up on youtube

Once you're in you want to type "cd /" then hit enter, then type "cd tools" then hit enter and then type "ls" if you see your tools you've installed, then everything is completely normal and fine. Else, I don't know what could be wrong...

Be sure to copy the tools again after you made the factory reset

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...