Jump to content

Kismet-hak5 on Tetra 2.6.2


Recommended Posts

Has anybody successfully installed the kismet-hak5 or kismet-remotecap-hak5 packages with firmware 2.6.2? According to Foxtrot's post in the release thread, it should just require:

opkg update
opkg install kismet-remotecap-hak5

But I get the following:

Installing kismet-remotecap-hak5 (2019-09-01-1) to root...
Downloading https://downloads.hak5.org/packages/mk6/1907/kismet-remotecap-hak5_2019-09-01-1_mips_24kc.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kismet-remotecap-hak5:
 * 	protobuf-lite>
 * opkg_install_cmd: Cannot install package kismet-remotecap-hak5.

I've tried installing all the dependencies (including protobuf-lite & libprotobuf-c) in the makefile  , but no luck, same error. I get the same problem with both kismet-hak5 and kismet-remotecap-hak5. Have tried flashing the firmware a couple times but that had the same results.

Any suggestions are appreciated.

Link to comment
Share on other sites

For anyone with the same problem, I seem to have solved it. First, need to run

opkg install libprotobuf-c

Then, install kismet-hak5 or kismet-remotecap-hak5 and ignore dependency errors:

opkg install kismet-remotecap-hak5 --force-depends

It still complains, but it installs and seems to work fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...