Jump to content

OpenVPN Client Connection Resets Interface


PatriotPaul
 Share

Recommended Posts

I have a PiVPN running at my home and it is tested and working as expected, routing all traffic through the VPN to the home network and then back out. I have tested then on my Android phone, MacBook and Pixel Slate. I feel confident it is getting the job done. I am currently out of the country and I am using my Pineapple TETRA as a gateway onto the hotel network. I have been trying to get OpenVPN on the Pineapple going but when it connects, the wireless interface I am connected to disappears/resets. The light on the front of the TETRA switches from Blue to Amber, the wireless disappears for a short while and then returns. The pineapple uptime indicates that it did not reboot so it appears that the interface(s) reset for some reason. I have tried initiating a connection to ProtonVPN as well with the same results. I used a combination of Hak5 YouTube videos and this documentation - https://openwrt.org/docs/guide-user/services/vpn/openvpn/client to setup the Pineapple.

Pertinent Details:
Firmware: 2.6.2
OpenVPN: openvpn-openssl - 2.4.7-2

Here is a scrubbed copy of the configuration:

client
#dev tun
proto udp
remote vpn.domain.tld 1194
resolv-retry infinite
nobind
persist-key
persist-tun
remote-cert-tls server
tls-version-min 1.2
verify-x509-name vpn_33b22ab9-0e3d-405a-956c-80e657c57c54 name
cipher AES-256-CBC
auth SHA256
auth-nocache
verb 3
<ca>
-----BEGIN CERTIFICATE-----
...
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
...
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
...
-----END PRIVATE KEY-----
</key>
<tls-crypt>
#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
...
-----END OpenVPN Static key V1-----
</tls-crypt>
user nobody
group nobody
dev tun0

Can anyone else confirm this issue? I have done a good bit of digging but I suspect I am not phrasing my queries succinctly enough to determine if this is a known issue or bug or simply a configuration error. Any assistance or direction is greatly appreciated.

Link to comment
Share on other sites

  • 4 weeks later...

Hi @Foxtrot & @PatriotPaul ,... I am having the exact same problem. Out of country - my vpn is ok but openvpn on my tetra is no longer working.

I am on the latest version of the software on the pineapple and my vpn is no longer working. It was working on a previous version but I have updated recently....

 

Any troubleshooting or work arounds would be great.. Hate to be on hotel wifi without a vpn on my router :)

Link to comment
Share on other sites

  • 2 weeks later...

Hi there,

Same here, Pineapple nano / last firmware / openvpn, connection resets and ssh session closed...
Tested with Management ap AND with eth1/USB ethernet !
The connection disapears then comes back but the vpn tunnel disconnected.

No error/information/log....

Link to comment
Share on other sites

  • 3 weeks later...

Bump

Just received a Tetra for Black Friday and it is doing the same as reported here.
I have two nanos running older firmware, iptables, and an older version of openvpn-openssl.

When I run openvpn --config /etc/openvpn/myconfigfile, it appears to start the connection, then basically power cycles the tetra.
Something has definitely changed and I'm stuck not updating the nanos until a resolution is discovered.  

This is a great feature and it would be nice to get it working again.  Not sure why they seem to deprecate so much.
I have to adjust various code nearly every revision of openvpn and receive zero additional benefits. 

I've listed the versions that are currently working for the nano.

openvpn-openssl - 2.3.6-5
iptables - 1.4.21-1
iptables-mod-ipopt - 1.4.21-1
iptables-mod-nat-extra - 1.4.21-1

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 11 months later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...