Jump to content

Got a pc related problem that i cant fix :(


Niklz
 Share

Recommended Posts

hi there, havnt posted in a while but i think the show rocks. ive tried googling and ive found solutions that don't help me :(

my problem is when i do anything with large files, i get DELAY WRITE FAILURE msgs and my pc crashes. its especially bad with torrents, annoying thing is it corrupts the data alot.

things ive tried

turned off write cacheing and all discs

formated more times than i can remember

used Cacheman to minimize the cacheing more

thats about it, any suggestions would be fantastic... think ill pop into IRC later so ill keep this topic posted

cheers

Link to comment
Share on other sites

If it's an external drive, it's fucked:

"I received a delayed write failure error messages while copying data from an internal large capacity (200 GB) hard drive to a large capacity (250 GB) Maxtor drive connected to a USB2 enclosure. After copying about 60 GB data, the delayed write failure messages kept coming and the transfer slowed to a halt. I did some research on Google which referenced all kinds of issues and partial solutions. But all I had to do was connect the 250 GB drive internally through the IDE interface and the data transfer was flawless. It appears to be either a buffer or a cache issue and the USB2 transfer for large amounts of data caused problems that the internal transfer didn't. My data is now safely backed up on a hard drive and stored in a bank safety deposit box."

OR

Maybe you need to tweak your BIOS:

http://support.microsoft.com/kb/330174

OR

Maybe you need a new hard drive:

http://www.ebuyer.com/UK/product/115418

Link to comment
Share on other sites

its not an external drive, and ive had a look at that site a few times.

heres my setup

320gb sata brand new

160gb ide 3 years old

120gb ide 3 or 2 years old

and my board is asus A8N-SLI SE

i was told perhaps flashing my bios will help... any tips and or advice on this would be great,

is there any chance its my ram..?

Link to comment
Share on other sites

from what ive read i'd say it's the cache on the hard drive in question, whichever it is. hard drives do die as im sure you know.

flashing ur bios is fairly straightforward if you're familiar with reconfiguring the bios, just head over to http://www.asus.com/ i'm sure there's some instructions.

doesnt sound like your ram, but do you have any spare ram about to eliminate that?

Link to comment
Share on other sites

its nice you read past the first post....

its not a usb external drive, anyone else with constructive ideas?

You may want to try plugging one dirve in at a time, maybe in a different box. Maybe you can see which one is messed up.

Also if you get an error message post it, A screenshot may be helpful too.

Link to comment
Share on other sites

ermm nah im not running fat32, ill try unplugging some of them and keep you guys posted, might not be today ive got a shit load of uni work to do.

and yeah its .iso's and avis anything over a gig it normally kicks up a fuss

but thats not to say it doesnt for other files its just more likely

Link to comment
Share on other sites

Few other questions. What OS, version, updates,e tc. What other hardware involved (video, attached devices, etc) what services are running? Indexing turned on or off?

Link to comment
Share on other sites

digip and everyone i hope this answers yous ques..

and whats spinrite? ill dl it it and let you know (never used it b4 tho..)

copied from everest

Computer

Computer Type ACPI Multiprocessor PC

Operating System Microsoft Windows XP Professional

OS Service Pack Service Pack 2

Internet Explorer 6.0.2900.2180 (IE 6.0 SP2)

DirectX 4.09.00.0904 (DirectX 9.0c)

Computer Name NIKLZ-PC

User Name niklz

Logon Domain NIKLZ-PC

Date / Time 2007-01-28 / 10:50

Motherboard

CPU Type DualCore AMD Athlon 64 X2, 2400 MHz (12 x 200) 4600+

Motherboard Name Asus A8N-SLI SE (3 PCI, 1 PCI-E x1, 1 PCI-E x4, 2 PCI-E x16, 4 DDR DIMM, Audio, Gigabit LAN)

Motherboard Chipset nVIDIA nForce4 SLI, AMD Hammer

System Memory 1536 MB (PC2700 DDR SDRAM)

BIOS Type Award (03/09/06)

Communication Port Communications Port (COM1)

Communication Port ECP Printer Port (LPT1)

Display

Video Adapter GeForce 7900 GT (256 MB)

Video Adapter NVIDIA GeForce 7900 GT (256 MB)

3D Accelerator nVIDIA GeForce 7900 GT

Monitor Plug and Play Monitor [NoDB]

Multimedia

Audio Adapter Realtek ALC850 @ nVIDIA nForce4 SLI (CK8-04) - Audio Codec Interface

Storage

IDE Controller NVIDIA nForce4 Serial ATA Controller

IDE Controller NVIDIA nForce4 Serial ATA Controller

IDE Controller Standard Dual Channel PCI IDE Controller

Storage Controller MagicISO SCSI Host Controller

Disk Drive Maxtor 6Y120L0 (120 GB, 7200 RPM, Ultra-ATA/133)

Disk Drive Maxtor 6Y160P0 (160 GB, 7200 RPM, Ultra-ATA/133)

Disk Drive WDC WD3200KS-00PFB0 (298 GB, IDE)

Optical Drive HL-DT-ST DVDRAM GSA-H10A (DVD+R9:8x, DVD-R9:4x, DVD+RW:16x/8x, DVD-RW:16x/6x, DVD-RAM:5x, DVD-ROM:16x, CD:48x/32x/48x DVD+RW/DVD-RW/DVD-RAM)

Optical Drive MagicISO Virtual DVD-ROM0000

SMART Hard Disks Status FAIL

Partitions

C: (NTFS) 117232 MB (107903 MB free)

E: (NTFS) 305234 MB (118545 MB free)

Z: (NTFS) 156327 MB (1844 MB free)

Total Size 565.2 GB (222.9 GB free)

Input

Keyboard Standard 101/102-Key or Microsoft Natural PS/2 Keyboard

Mouse Microsoft USB IntelliMouse Optical

Network Adapter NVIDIA nForce Networking Controller - Packet Scheduler Miniport (192.168.1.1)

Peripherals

USB1 Controller nVIDIA nForce4 SLI (CK8-04) - OHCI USB 1.1 Controller

USB2 Controller nVIDIA nForce4 SLI (CK8-04) - EHCI USB 2.0 Controller

USB Device Microsoft USB IntelliMouse Optical

DMI

DMI BIOS Vendor Phoenix Technologies, LTD

DMI BIOS Version ASUS A8N-SLI SE ACPI BIOS Revision 0502

DMI System Manufacturer System manufacturer

DMI System Product System Product Name

DMI System Version System Version

DMI System Serial Number System Serial Number

DMI System UUID 809E048F-9C7ADA11-B3D60011-2FF29574

DMI Motherboard Manufacturer ASUSTeK Computer INC.

DMI Motherboard Product A8N-SLI SE

DMI Motherboard Version 1.XX

DMI Motherboard Serial Number 123456789000

DMI Chassis Manufacturer Chassis Manufacture

DMI Chassis Version Chassis Version

DMI Chassis Serial Number EVAL

DMI Chassis Asset Tag 123456789000

DMI Chassis Type Desktop Case

DMI Total / Free Memory Sockets 4 / 1

Problems & Suggestions

Problem Disk free space is only 1% on drive Z:.

let us know if theres more info u want

cheers in advance

Niklz

Link to comment
Share on other sites

i just ran spinrite, and it says my sata is critical =/ but its only about 3 months old if that...

someone on hak5 irc said it could be my sata controller, and looking at the text from everest

"Disk Drive WDC WD3200KS-00PFB0 (298 GB, IDE)"

it says its IDE?? is this normal?

niklz

Link to comment
Share on other sites

Is System Restore on for the extra drives? Are they just used for storage and no oerating systems or sys file son them? If not, then turn off system restore for the extra drives - Drive Z on has 1% free? Is this the one your copying to/from or moving from when the error occurs.

Check your NIC card for updated drivers. You said it happens on most torrents, possibly an online connection problem with the lan card and buffering issues. Try copying files with the lan card disabled (offline, from one disc to another). Check for bad IDE cables (usually a simple fix) or hardware connections.

Also, a lot of people sued to get this error with external drives hooked up through USB. Try removing the SATA drive and just use the other two and see what happens. It may be confilcting with one of the other pci cards, like video or lan. Check hardware settings and see if they are sharing any irqs. (right-click my computer, then properties, hardware tab, device manager, and change view to "Devices by connection" See if anything has a little yellow exclamation point or your pci are sharing any connections or pci to usb is having problems. Something in there could be misconfigured or conflicting.

Most likely its something simple, but I woul dbe the drive is actually ok and it is a problem somewhere in the connections.

One last thing to try is change your virtual memory for the exta drives and give them less/more depending on th eamount of ram you have. You may be running into a wall if your not allocating enough swap space and sys restore is holding un accounted for space during your moving or downloading of files.

Link to comment
Share on other sites

just read this :

DELAY WRITE FAILURE: I am a Microsoft support engineer for Windows XP and had a customer call in with the write delay error and was able to fix her by downloading a XP driver for her disk controller card. When she installed XP, and this is true for everyone, the installation put a MS generic driver for her controller. We went to the mfg's web site and downloaded the XP driver for the card and her problem is now resolved. She was getting this error when trying to write above 140 gig on a 200 gig Maxtor 2000. Go to device manager and she if you disk controller has a Microsoft driver with a date of 6/2001. If you have that driver installed go to the mfg's web site for your card and get their XP driver and your problem should be resolved

So make sure Windows is not the default driver for your hard drive disk controller card. You should check your manufacturers website for updated drivers. This may not fix your problem but give it a shot.

Check under hardware settings and check the driver for each drive. If it is from Microsoft and or from 2001, you may need the updated driver.

Also, you may be running into fragmentation issues. You cannot defrag a drive without enough space for the defrag to take place, but this may clear up some of the problems. Hak5 did a good episode explaining defrag and what the minimum space requirements were (can't remember off the top of my head) You may need to free up some space and clean up the disk

(turn of indexing on all drives if it is currently turned on - forgot to ask this before - but it will severely impact your disk access and is not needed unless your searching under administratvie tools for certain text within a file)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...