Jump to content

modules not working on new Tetra


cato666
 Share

Recommended Posts

Hi

 

I just received a new Tetra and having updated firmware to 2.60, went to install a bunch of modules from the WebUI, including ettercap, nmap and sslsplit, amongst others. They all downloaded and a few packages are working fine but others including these  show as missing depencies which wen you click to install, try to but ultimately nothing changes.

 

I tried doing so manually via openpkg over ssh, but it's not finding the package, in the case of ettercap at least. The openpkg community feed appears to be set to https://downloads.hak5.org/packages/mk6/1907. The gz package that gets pulled down from there that lists available packages contains only about 5 packages.

 

How do I go about getting these community modules installed?

 

Thanks

Link to comment
Share on other sites

30 minutes ago, cato666 said:

Hi

 

I just received a new Tetra and having updated firmware to 2.60, went to install a bunch of modules from the WebUI, including ettercap, nmap and sslsplit, amongst others. They all downloaded and a few packages are working fine but others including these  show as missing depencies which wen you click to install, try to but ultimately nothing changes.

 

I tried doing so manually via openpkg over ssh, but it's not finding the package, in the case of ettercap at least. The openpkg community feed appears to be set to https://downloads.hak5.org/packages/mk6/1907. The gz package that gets pulled down from there that lists available packages contains only about 5 packages.

 

How do I go about getting these community modules installed?

 

Thanks

i think you have to wait a bit the group hak5 go fix the problem in the coming days
 
Edited by fan
Link to comment
Share on other sites

5 hours ago, cato666 said:

Ok cool thanks. Just seen the thread at 

 

hi
I have not yet seen if the problem is already solved, a week has passed and there is nothing special always the same problems  hoping for good news on Monday
 
 
Link to comment
Share on other sites

11 hours ago, fan said:

any information about how to downgrade wifi pineapple firmware than  2.6.x   to 2.5.x

firmware recovery.  a factory reset then downgrading is not a good idea

Link to comment
Share on other sites

  • 2 weeks later...
1 hour ago, swapsakker said:

How do you downgrade to 2.5 ?

Refer to the following post:

On 8/19/2019 at 10:48 AM, Cap_Sig said:

Just curious, what firmware version did you have prior to updating?

Had an issue over the weekend that could not get 2.6 to work correctly updating from 2.4.1 and 2.5.0

The following steps ended in a successful upgrade to 2.6.0

  1. Firmware Recovery (loads firmware 2.4.1)
  2. Manual update to version 2.5.4
  3. Over the Air install of version 2.6.0 firmware

This is the only method I found to successfully update the tetra on any firmware older than 2.5.4 installed (only tested a few versions).  Even a manual install of 2.6.0 from 2.4.1 recovery yielded in PineAP having several issues and failing to start the daemon. 

Just skip the last step for OTA update to 2.6.0

Factory recovery info here: https://docs.hak5.org/hc/en-us/articles/360010471774-Firmware-Recovery  Be sure to download the correct factory recovery firmware.

Then do this for manual update to 2.5.4  https://docs.hak5.org/hc/en-us/articles/360025819673-Manual-Firmware-Installation

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...