Jump to content

autossh and sshfs do not work on Turtle v6


josealmeidajr
 Share

Recommended Posts

Hello,

I've been trying to setup the turtle to autossh back to a ec2 VPS. I've gone through all the configuration steps bellow:

1)Installed keymanager, and autossh

2)Generated key

3)Copied key to VPS

4)Configured autossh to point to my vps.

I've looked into /etc/config/autossh and it has the correct settings like:

config ssh '-i /root/.ssh/id_rsa -N -T -R 2222:localhost:22 user@myvpsdomainname.com -p 22 '

I've copied and pasted this like removing the "config" and the single quotes, and it connects to my VPS with no issues.  

 

In the turtle module it shows as "STARTED" and "ENABLED", but it does not connect at all. Only if I manually leave the turtle and run the ssh command above.  

 

Same goes for sshfs, configured, enabled/started and it simply does not do anything. 

 

Turtle running on the newest firmware. 

Link to comment
Share on other sites

  • 2 weeks later...

Same problem here. But many of the modules do not run automatically if configured so.

Maybe it is a problem with dependencies. As I read the OS is 19.07 now and I also had some trouble to get QuickCreds running. The missing dependencies had to be manually downloaded and installed and could not be loaded via opkg packet manager.
I also had a look at the modulemanager itself - but the scripts seem identical to me.
 

Link to comment
Share on other sites

  • 3 weeks later...

I have been able to recreate this and found the bug to be related to a missing dependency in firmware v6.1. We're working on a patch now. 

The workaround now is:

1. Manually add the remote host to the known host file by first connecting via ssh command in the shell. 

2. Edit /etc/config/autossh and change enabled from 0 to 1 (or delete and reinstall the autossh module which fixes this issue) 

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
On 11/16/2019 at 7:24 AM, Digit said:

Manual start it :

autossh -M 5122 -N -R 5022:localhost:22 your_USER_VPN@your_vpn_IP

 

Hi,

Sorry but I don't understand, I followed this video below, with the same parameters but when I do ssh root@localhost -p 2222 from my vps, I have a "connection refused".

My turtle is connected to my laptop and I use an ssh connection to my vps as root.

I removed "the known_hosts" files from my turtle and my vps. On the VPS server, I can see my key in authorized_key.

If I do ssh "myuser@mypvs.xx" from my LAN Turtle, it works.

If I do "autossh -M 5122 -N -R 5022:localhost:22 your_USER_VPN@your_vpn_IP" , as you mentionned, from my LAN Turtle, I haven't got any error message, so I supposed that it works. but after that, I try again ssh root@localhost -p 2222 from my vps, and it still not working.

Could you help me please? I need to access to my LAN TURTLE from my VPS.

Thank you in advance

 

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...