Jump to content
Foxtrot

[RELEASE] LAN Turtle Firmware v6.X

Recommended Posts

Hi!

We're happy to announce the release of firmware version 6 for the LAN Turtle. Alongside the updates for the WiFi Pineapple and the Packet Squirrel, this release brings a multitude of package updates, and provides an up-to-date kernel and base firmware.

6.2 Change Log:

  • General
    • Fix an issue affecting package installation and signature verification.
    • Fix an issue where the module status would report incorrectly in the Turtle shell.
  • AutoSSH
    • Fix an issue where single quotes would be displayed in the user input box.
  • Misc
    • Work around a kernel bug causing packet filtering to fail in some tools. Thank you @adde88!
    • Remove PHP from the firmware.

6.1 Change Log:

  • General
    • Fix an issue where modules would not be listed when attempting to download them from the LAN Turtle module repository.

6.0 Change Log:

  • General
    • Update base firmware from OpenWRT 15.05 to 19.07.
    • Improve 3G connectivity for 3G LAN Turtle.
  • Modules
    • Fix install issues with QuickCreds.

 

- The Hak5 Development Team

Share this post


Link to post
Share on other sites

Hi,

 

is there a simple way to backup all my stuff before the upgrade?

It is tedious to set up everything again and again after an update

Share this post


Link to post
Share on other sites

How would one update to version 6?  It's around 15mb and from the screen shot below, you can see that my freshly factory reset turtle doesn't have the required space to copy it to /etc/.

QEkR5Lh.jpg

Share this post


Link to post
Share on other sites
7 hours ago, russianhacker8 said:

How would one update to version 6?

You can update from within the menu system

image.png.39053819f77726e58e0001425475b384.png

Or you can download it to the LT /tmp/ which as its located in RAM has more space.

 

Edited by Just_a_User

Share this post


Link to post
Share on other sites

/etc/opkg/customfeed.conf has a nonexistent url

opkg update produces signature errors

urlsnarf ist missing

 

Regards

Rainer

Share this post


Link to post
Share on other sites

I have the same error message :

*** Failed to download the package list from http://downloads.openwrt.org/packages/turtle/1907/Packages.gz

 

Share this post


Link to post
Share on other sites

This URL give the Packages.gz file 

https://downloads.hak5.org/packages/turtle/1907/Packages.gz

But the corresponding signature file is not found on this address.

An opkg update is successful with this URL (/etc/opkg/customfeeds.conf) and with signature checking disabled (/etc/opkg.conf)

  • Like 1

Share this post


Link to post
Share on other sites
On 9/21/2019 at 9:10 AM, francois said:

This URL give the Packages.gz file 


https://downloads.hak5.org/packages/turtle/1907/Packages.gz

But the corresponding signature file is not found on this address.

An opkg update is successful with this URL (/etc/opkg/customfeeds.conf) and with signature checking disabled (/etc/opkg.conf)

Thanks for reporting this, I'll release an update as soon as possible with the fix.

Share this post


Link to post
Share on other sites
On 9/21/2019 at 3:10 AM, francois said:

This URL give the Packages.gz file 


https://downloads.hak5.org/packages/turtle/1907/Packages.gz

But the corresponding signature file is not found on this address.

An opkg update is successful with this URL (/etc/opkg/customfeeds.conf) and with signature checking disabled (/etc/opkg.conf)

Thanks for the info, @francois.

Share this post


Link to post
Share on other sites
2 hours ago, PaleEmp1re said:

i did the upgrade to 6x and now my lan turtle is looking like this, i have the 3G version.

how do i get it back to factory, its all messed up now

Na, it's putty. You need to set the. Remote character set the translation window.

To how I have set it.

putty.png.bd5ca50bb510818f80ec3859e8e7af2a.png

Edited by Jtyle6
Mini edits.

Share this post


Link to post
Share on other sites

first thank you very much it worked, ok second issues

if i go to update it says no internet see below

https://www.dropbox.com/s/3p0uqsutc1mykh5/pic3.PNG?dl=0

then if i go here to update module

https://www.dropbox.com/s/yrb61xo2pif7e1x/pic4.PNG?dl=0

also it says no modules

https://www.dropbox.com/s/8xq2o01qhocaatq/pic5.PNG?dl=0

and module manager do not want to start

https://www.dropbox.com/s/9zvuw6r9ot4e8a9/pic6.PNG?dl=0

something serous went messedup, i wonder if you can wipe it and delete everything and reload it via FTP to the lan turtle?? it feels like its not just the update that went wrong but swetup files like openvpn is also messed up

any ideas??

Share this post


Link to post
Share on other sites

Pale Emp1re

There is a factory reset doc located at https://docs.hak5.org/hc/en-us/categories/360000979313-LAN-Turtle with the other docs. It is easy to reset. Just make sure you download the factory recovery firmware and not the the standard build. Also on my Turtle 3G the reset button was on the other side from the pictures in the manual but still worked as documented. 

Hope it helps. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...