Jump to content

Recommended Posts

  • Replies 113
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hey there - welcome to the community!  I understand that the modules and payloads are a big factor of Hak5 gear, and it's our goal to create powerful pentest platforms that make it convenient to

Hi! We're very excited to announce the release of the 2.6.x Firmware for the WiFi Pineapple TETRA! We've been working hard behind the scenes, listening to the great community feedback and bu

Having the same issue, updated to 2.6 now I can't install Module dependencies, modules that don't require additional dependencies like theme for instance work fine but for other modules like wps I can

Posted Images

So maybe someone can help see if I can easytether installed so I can tether my phone to my pineapple and use it on the go. I get the correct .ipk file and when I attempt to install it, im running into this:

Quote

root@Pineapple:~/15.05.1/ar71xx/generic# opkg install easytether-usb-openssl_0.8.9-3_ar71xx.ipk
Unknown package 'easytether-usb-openssl'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for easytether-usb-openssl found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package easytether-usb-openssl.

This was working before the 2.6.X update. Downloading the drivers from easytethers official site. I've tried both opennssl and tiny. I also attempted 18.06+ as well.

Edited by byte
Link to post
Share on other sites
8 hours ago, laudarch said:

Am stuck with an IPv6 address, I can't access the webpage or ssh.

After 2 reboots I have IPv4 and the microSD is stable, some package dependencies don't install, apart from that am good. Maybe its time to opensource the pineapple for more hands(this in no ways means the hak5 team is not awesome).

 

Link to post
Share on other sites

Also is anyone else having issues with site survey? I click start the process but it won’t capture the handshake, the WiFi Pineapple nano loses internet connectivity And I get weird one letter names at the bottom where the attacked networks are supposed to be. I’ll upload a screenshot when I get home. I am on 2.6.1.

Link to post
Share on other sites
21 hours ago, Pentoman said:

Sendmail module is missing in firmware ....
Reporting is not working , sendmail realted func,
would be nice to get a fix 

Yes. I have moticed this, after playing around with email setting for a morning trying to get it to work.

Link to post
Share on other sites

Hi guys,
Yesterday I received my second Pineapple, a Tetra this time. During the installation I choose the 2.5.4 firmware version because after the upgrade to the 2.6.1, the modules on my Nano stop working and I was forced to make a downgrade to the 2.5.4. My request (and I believe the everyone that have an Pineapple thinks the same) is a list from someone that is using the 2.6.1 version on Tetra and Nano of all the modules that are working 100% and the modules that not working at all or with limitations (like dependencies that are not installing).
Thanks a lot!  
 

Link to post
Share on other sites
  • 2 weeks later...

I’ve got my tetra in a bit of a sweet spot for me with version 2.5.4. If I update the modules (either/any/all of the hak5 modules or third-party), is there a good chance they’ll stop working for FW 2.5.4? Normally I don’t mind doing a full reset but at the moment, my tetras been up for 24+ days and I want to keep it going.

Link to post
Share on other sites
On 9/12/2019 at 3:46 AM, L3N1 said:

Hi guys,
Yesterday I received my second Pineapple, a Tetra this time. During the installation I choose the 2.5.4 firmware version because after the upgrade to the 2.6.1, the modules on my Nano stop working and I was forced to make a downgrade to the 2.5.4. My request (and I believe the everyone that have an Pineapple thinks the same) is a list from someone that is using the 2.6.1 version on Tetra and Nano of all the modules that are working 100% and the modules that not working at all or with limitations (like dependencies that are not installing).
Thanks a lot!  
 

Adding to list as time allows.

Link to post
Share on other sites
On 9/14/2019 at 12:41 PM, Altrez said:

Is anyone working on a fix for the 2.6.1 firmware or do we need to downgrade for now?

@Foxtrot has said in previous posts that he is working on updating the modules to work with 2.6.x as time allows.  Since these are community modules hopefully some creators update there modules as well to make the process go faster.

If you are wanting a certain module to work try downgrading to firmware recovery version.  Also some users report 2.5.4 working with certain modules as well.  This is the best fix to get a module working until the updated modules are released.

Link to post
Share on other sites
15 hours ago, Forkish said:

I’ve got my tetra in a bit of a sweet spot for me with version 2.5.4. If I update the modules (either/any/all of the hak5 modules or third-party), is there a good chance they’ll stop working for FW 2.5.4? Normally I don’t mind doing a full reset but at the moment, my tetras been up for 24+ days and I want to keep it going.

If it is working the way you want I wouldn't upgrade anything until confirmed working module releases are done.  You will run the risk of some modules not working if updates have been done since your last install.  

Link to post
Share on other sites
On 9/23/2019 at 7:38 AM, Cap_Sig said:

If it is working the way you want I wouldn't upgrade anything until confirmed working module releases are done.  You will run the risk of some modules not working if updates have been done since your last install.  

Thank you. I’m going to try it with my nano and see what happens.

Link to post
Share on other sites

I have installed the 2.62 firmware on my Pineapple Tetra, but I still have issues in that Recon does not unction in 'continuous' mode, and that email notifications are still not working. Is anyone else having these problens

 

Peter

Quote

 f

 

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

I am not 'super excited' about firmware releases that seem to want to 'boil the ocean' and end up crippling or disabling fundamental functionality. Incremental bug fixing in smaller releases that have undergone component, system, factory and UAT test phases would result in more stable firmware releases.

On the eve of a real client assignment, my Tetra has effectively been disabled by a textbook 2.6.2 firmware upgrade that went without a hitch but left the Recon function dead- scans and finds nothing.

So, today I am resorting to android store app to discover wifi devices - on my phone. Seriously?

 

Link to post
Share on other sites
12 minutes ago, BlackOp said:

2.6.2 firmware upgrade that went without a hitch but left the Recon function dead- scans and finds nothing.

It still works. But the live updates don't work. 

Link to post
Share on other sites
26 minutes ago, Jtyle6 said:

It still works. But the live updates don't work. 

Ok. So I run a Recon. After a while it shows nothing. I stop the scan.. It says nothing found. No errors are shown. My screen shows nothing. How is that working? 

Edited by BlackOp
Link to post
Share on other sites
  • Foxtrot unfeatured, unpinned and locked this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...