Jump to content

USB rubber Ducky won't work

Recommended Posts

I got my duck yesterday for my birthday, I used the default script hello world and it worked perfectly but when I tried to use a different scrips it did not work, i tried multiple different codes and all of them did't  work i tried increasing the delay as well and it still did't work any help would be amazing 

Share this post

Link to post
Share on other sites
Posted (edited)

what tool are you using to encode your scripts with? I have heard that the online tool is a little bit buggy from time to time. The best way is to use the java encoding tool.


Then to compile MyDuckScript.txt

$ java -jar encode.jar -i MyDuckyScript.txt -o inject.bin

in linux. If you have windows it might be something like this:

C:\> java.exe -jar encode.jar -i MyDuckyScript.txt -o inject.bin

But you have to make sure you have the java runtime engine installed before you can execute the .jar file

Edited by kdodge
added more instructions

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...