Jump to content

BB Update to 1.6 issues


Recommended Posts

I followed the update readme from the hak5 page but I am failing to update, I tried two methods, 1. running the bunnyupdater script and 2. copying the 1.6 update folder to the root and rebooting. I failed completely to run the updater as it looks to not be executable when in the root of the BB and the update folder method looks to have worked but the version check file shows 1.5_298 not 1.6. I am running this on a 64bit ubuntu 19.4 machine.

1.Downloaded the 1.6 firmware

2. Downloaded the bunnyupdater zip for linux 64

3. Put bashbunny into arming mode and plugged in

4. Extracted the bunnyupdater, using ubuntu built in archive manager, to the root of my BB

5. In a local but sudo terminal session, I added the variable "BUNNYPATH=/media/$USER/BashBunny ./bunnyupdater" but got "-bash: ./bunnyupdater: No such file or directory"

5. Tried to CHMOD +x the script but not able to, it reverted back each  time to the original permissions

6. Tried the "copy the upgrade folder" for 1.6 onto the device and followed the update process which looked to have completed but the version.txt file on the BB is showing 1.5_298

Any thoughts from the Hak5 experts on why I can't CHMOD the script or why it isn't working ?


Link to comment
Share on other sites

I had a similar problem. I couldn't make it executable no matter how high I raised my privileges.

Also, the recommended way in linux with the bunnypath environment variable also didn't work: the updater couldn't determine the bunny firmware and would exit.

I ended up doing a factory reset: 

After that, the updater was able to detect and run.
I was still in Windows when I tried the fix, so I just used the updater there and cannot currently confirm if it would have worked in linux as well. But I had a similar symptom and a factory reset helped. Worth a shot if you're still stuck.

Link to comment
Share on other sites

Got it to work:

  • Download the updater to a local drive such as Downloads

  • Unzip the file to the same location in Downloads

  • Terminal to Downloads (not on the BB) and chmod +x bunnyupdater script

  • Plug in the BB in arming mode to a USB port

  • From the terminal type:

  • BUNNYPATH=/location/of/the/bashbunny/root ./bunnyupdater

    • (i.e. BUNNYPATH=/media/$USER/BashBunny ./bunnyupdater)

  • Bash Bunny Updater should now start from the Downloads terminla session

  • Once told to, you can safely eject the BB wait 10 seconds and plug it back in to the same USB port

  • Blue and Red LED will flash, then when its completes the firmware update a blue flashing light will be shown

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...