Jump to content
SystemCrash86

Kali linux crackling sounds

Recommended Posts

Hi, I am having a very unusual problem with my Kali Linux install on my laptop.

Everything works fine except for the audio recently, it has started to make loud crackling noises and such... Like the mic and speakers are too high or interfering with each other.
But the problem persists even when I mute everything. This is a recent problem that started within the last week and I have no idea how to fix and I am reluctant to do another install because I tried a kali linux live USB and seemed to have the same problem.

I narrowed this down to kali linux because I tried a live USB if Linux nate and appeared to have no issues at the time.

Hope someone can help

Share this post


Link to post
Share on other sites

it might be a driver issue, but you are going to have to find out which driver it is, I'm not sure about that.

maybe try a few commands to get some info about your system, (this will hopefully tell you about sound kernel modules that you have loaded):

$ lsmod | grep 'snd_'


and this will tell you about your sound hardware:

$ sudo lshw -C sound

 

Edited by kdodge
didn't post correctly

Share this post


Link to post
Share on other sites

Here is the output:

 

root@kali:~# lsmod | grep 'snd_'
snd_hda_codec_hdmi     57344  1
snd_soc_skl           114688  0
snd_soc_skl_ipc        73728  1 snd_soc_skl
snd_soc_sst_ipc        16384  1 snd_soc_skl_ipc
snd_soc_sst_dsp        36864  1 snd_soc_skl_ipc
snd_hda_ext_core       28672  1 snd_soc_skl
snd_hda_codec_realtek   122880  1
snd_soc_acpi_intel_match    24576  1 snd_soc_skl
snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl
snd_hda_codec_generic    86016  1 snd_hda_codec_realtek
snd_soc_core          253952  1 snd_soc_skl
snd_compress           24576  1 snd_soc_core
snd_hda_intel          45056  9
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           94208  7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_skl
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               114688  8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core
snd_timer              36864  2 snd_pcm
snd                    94208  26 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
root@kali:~# sudo lshw -C sound
  *-usb:0                   
       description: Video
       product: HP Truevision HD
       vendor: Sonix Technology Co., Ltd.
       physical id: 5
       bus info: usb@1:5
       version: 1.03
       capabilities: usb-2.00
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
  *-multimedia
       description: Audio device
       product: Sunrise Point-LP HD Audio
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 21
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: irq:128 memory:96228000-9622bfff memory:96210000-9621ffff
root@kali:~# 

 

Share this post


Link to post
Share on other sites

Okay, you probably need to file a bug report at https://bugzilla.kernel.org/

There's a tool that they will probably ask you to run,

$ alsa-info

I guess it collects a lot more info about your system, and then sends it to www.alsa-project.org automatically. But I would wait to run that until they tell you to.

Share this post


Link to post
Share on other sites

If it is a driver problem, then I would expect you will have the same problem after you reinstall it, but it is something you could try. You said that the LiveUSB version of Kali also gives you crackling? Could you try a much older version of Kali LiveUSB (make sure to keep the networking disconnected when testing that, just because it will be a security hazard)? It may not have the same problems with audio that you are having right now. At least it wouldn't be too hard to test. If your audio works on an older kernel, but not on the current on, with some work you might be able to narrow down when (what kernel) audio stopped working for you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...