Jump to content

Problem with Pandora console shifting off screen after load


Recommended Posts

I have got PJ working fine (sorted the Flash 8 hack & got it recording MP3s ok)

I do have one problem though - When I load up Pandora's Jar in Firefox (localhost:8085)...

At first all seems fine but after Pandora completes loading, the Pandora window shifts up left so the buttons cannot be reached. There is no scrollbar or anything like that.

See this screenshot

It almost seems like a deliberate hack by Pandora to break Pandora's Jar

I did get it not move once by hitting F5 to reload but this doesn't seem to be working any more.

Has anyone else seen this? Any ideas how to fix. Can't find mention of it on the forum...

Thanks in advance for any help

Alex Bowyer

(email address is in the screenshot if you want it)

Link to post
Share on other sites
I have got PJ working fine (sorted the Flash 8 hack & got it recording MP3s ok)

what fix did you use for the "flash upgrade required" problem?

this looks like something related to CSS, do you have any related plugins?

The pandora player put itself in a div with id "TunerContainer" or in an iframe named "tunerFrame", i'm not sure which is the one that causes it to get displayed there.

<div id="TunerContainer">

            <iframe src="http://www.pandora.com/?cmd=mini" scrolling=no id="tunerFrame" name="tunerFrame"></iframe>

            <script type="text/javascript" src="js/pandora.js"></script>

        </div>

try putting a few line breaks ("<br>") in the pandoraGrabber.html file, just before the code shown above, let me know if this workaround works.

Link to post
Share on other sites
what fix did you use for the "flash upgrade required" problem?

I downgraded to flash 8 & used the "change values in pluginreg.dat" fix to convince pandora I have flash 9.

this looks like something related to CSS, do you have any related plugins?

Only CSS viewer - but that is currently not enabled.

try putting a few line breaks ("<br>") in the pandoraGrabber.html file, just before the code shown above, let me know if this workaround works.

Thanks for this tip - It didn't work directly (I guess <br> is ignored outside a div... However your pointing me to the right file enabled me to work out a workaround on the same lines.

Basically I moved the tuner container right to the end of the form (just before </form> tag. Then it was still moving up left and blocking settings panel - so I just duplicated the div that was right at the end of the </form> 5 times. This shifts the player down just enough so that when it moves up, it doesn't block anything. It's slightly ugly - but good enough for me.

I'm sure a CSS/HTML expert can come up with a better solution if others hit this.

Thanks again for your help!

Link to post
Share on other sites

Great to see that it's working for you,

I'm wondering what might cause this to render differently on your computer,

any special settings? special display adapter? special version of FF?

when have you installed FF?

how many plug-ins have you got installed?

Link to post
Share on other sites

I see the same problem on two different computers so I am not sure what is unique to me.

The one I'm at now is a plain Firefox 2.0.0.1 install with DownThemAll,Enhanced History Manager, FireBug, CSS Viewer, Googlepedia, StumbleUpon, TabBrowser Preferences and AllinOne Gestures.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...