Jump to content

Micro SD card not formatting in NANO


Recommended Posts

Okay so I've never used an sd card before seeing that I have both the Tetra and since recently the NANO. Because the NANO was telling me it has very limited space I grabbed a Sandisk Ulta 64GB micro sd card and inserted into the NANO. I tried formatting it using the gui option under advanced, however it did not repsond, showed my sd card under resources and it didn't give me the option to install modules on the sd card.

I look on the net for option and ended up formatting the card using mkfs.ext4 command. This seemed to have worked and when I ssh into my NANO it showed the sd card as /dev/sda1. But in the gui it still didn't show the sd card and I'm unable to use my card. So to prevent me in buying an sd card for no reason I thought I'd ask some help on the forum. I'm in no way a Linux specialist and more of a beginner, so be gentle with me.

O what I did do is remove the sd card reboot and check again, rebooted with the card in the NANO and all not showing in the gui. But it's showing in the ssh session. Below is the output of the fdisk -l.

Disk /dev/sda: 63.8 GB, 63864569856 bytes
255 heads, 63 sectors/track, 7764 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1   *           3        7765    62351360   7 HPFS/NTFS

Hope you guys can help me out with this.

Best regards,



Link to comment
Share on other sites

  • 3 weeks later...

Hey Billy,

Unfortunately nobody has taken any effort in replying, but I managed to figure out what the problem was for me....

When logging in to your NANO with ssh you can in the advanced menu the USB options. Below the USB you'll see a part with some config for the USB card for when you format the card. What you first need to do is do an fdisk. Just like in my first post. Then check how your card is displayed. For me it was  /dev/sda1 then I went back to my NANO usb format config and changed it to match my fdisk output. In my case the output looked like (check the BOLD option):


config mount
    option target '/sd'
    option device '/dev/sda1'
    option fstype 'auto'
    option options 'rw,sync'
    option enabled '1'


Like I said, this was the fix for me. Hope it'll work for you as well. Do keep in mind that the SD card might not be seen by the NANO every now and then. Just reboot your NANO and your computer. This also seems to fix that problem.


Best regards and lots of fun,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...