Jump to content

Pineapple won't connect to Samsung Galaxy S10+ for setup


Anrke
 Share

Recommended Posts

I just keep getting the message that it is waiting for the WIfi Pineapple to make a connection after I enable USB tethering....and it beeps every once in a while but then  it either asks if I have enabled USB tethering (I have) or then sometimes comes up with another error message. The Pineapple has a solid blue light so it has booted up before I started...

Link to comment
Share on other sites

The other  error I get is the the connecteddevice is unable to access data on this device. Reconnect the USB cable and try again. But when I do that it just goes through the same process again....the cable and connection should be fine...it was used earlier today to charge the phone successfully...

 

Link to comment
Share on other sites

  • 2 months later...

Just a note to say you're not alone.  My Galaxy S10+ also doesn't connect, or appear to detect the USB Ethernet device as it should.

I've tried the Samsung (bundled) USB-C adapter, but it just doesn't recognize it.  The S10+ *does* recognize other USB Ethernet adapters and hubs, so it appears perhaps the specific driver for this Ethernet adapter is missing from the Samsung build.  (Normally the S10+ works with Ethernet adapters quite well, and adds setting menu entries for IP and such.)

On the upside, he S10+ works just great over the WiFi management AP, and I've had no trouble using it from the standard Web and WiFi interface.  It's just the USB Ethernet that doesn't appear.

Link to comment
Share on other sites

  • 2 weeks later...

I have tried with USB Debugging (ADB port), and found no difference.  I think it's unrelated.

The Tetra presents a USB Device (Realtek RTL8152B controller VID 0BDA & PID 8152) over the Eth port on back.  So it's a USB connection to an Ethernet adapter inside the Tetra.

https://datasheet.lcsc.com/szlcsc/Realtek-Semicon-RTL8152B-VB-CG_C50656.pdf

This new USB attach needs to be added as an Ethernet device by the Android phone.  It seems to me like the Samsung S10+ just doesn't have a driver for this or doesn't load it.

I have other USB Ethernet devices, and they are correctly attached, enumerated, and discovered by the Samsung Linux kernel, and then manifest in the UI itself right from the pull-down settings as an "Ethernet" showing IP address and such (see picture of NON-Tetra device).  That is, the Samsung S10+ does have good easy USB Ethernet support, just not for the chip that Tetra is using.  If anyone knows a way to add a driver for it, post!  I couldn't find any way to do it.

 

ethernet.jpg

Link to comment
Share on other sites

Hey, try it now!  After the last Samsung S10+ over-the-air firmware update, it works!  I saw a reference in another forum that more ethernet adapters were added via updates, and it seems to be true.  The tetra Ethernet was detected without my changing anything.  It shows up as Ethernet eth0 now (instead of being ignored), and does get a DHCP address assignment of 172.16.42.118.

However, the Pineapple App still doesn't work -- it sticks in Waiting for Connection.  It's not possible to enable USB Tethering in the Samsung Settings, which remains greyed out.

I'm not entirely sure how this is supposed to work -- the phone sees a USB Ethernet adapter, lights it up, flashes Blue LED on Tetra, gets a DHCP assignment and gateway, and now believes it has access to the Internet over that connection (it does, when Tetra has its own Ethernet uplink).    Even in Airplane mode, all is fine.

So now the Samsung has full Internet, and access to the management page at http://172.16.42.1:1471/

Just like any laptop, really, same as "Windows / Linux" instructions.

So what's the Android App looking for?  Why does it need USB Tethering?  That seems like the Reverse model, where the Tetra would try to use Internet over cellular from the Samsung.   But how?   There's no way to do that with the USB Ethernet adapter, since it's an endpoint peripheral.  The Tetra would have to make an outbound (USB Host) connection to the phone, detect it as a (networking) device, and use the PHONE as an ethernet device for Tetra tethering to work.  That's how laptops do it anyway.

I tried disabling Ethernet in Samsung just to see if it would let me enable USB Tethering, but no.  It really wants to see a (USB Host!) laptop before enabling tethering.  I don't see how this would work on any phone, really.  What am I missing?

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...