Jump to content

No internet connection sharing (WP6)


KoreanGuy
 Share

Recommended Posts

I have a Tetra and a laptop with two wifi interfaces.  I have connected my Tetra to an ethernet connection and updated it previously.  In normal use, I would like to use it without it being connected to any other device.

The laptop has wlan0 and wlan1.  WLAN0 is my connection to my jetpack.  WLAN0 is the one I want to use to connect to the Tetra.  Changing the routing table (so the default route is WLAN0), everything works as expected from the laptop.  I can go to the internet and I can get to the pineapple's web page.

When I run WP6, I do the following:

    [C]onnect using saved settings
    [G]uided setup (recommended)
    [M]anual setup
    [A]dvanced IP settings
    [Q]uit

    
    Step 1 of 3: Select Default Gateway
    Default gateway reported as 192.168.1.99
    Use the above reported default gateway?             [Y/n]?

    Step 2 of 3: Select Internet Interface
    Internet interface reported as wlan0
    Use the above reported Internet interface?          [Y/n]?

    Step 3 of 3: Select WiFi Pineapple Interface
    Please connect the WiFi Pineapple to this computer.
    ...................................................
    ...................................................


192.168.1.99 is the interface IP of my WLAN0.  I press ENTER in step 2 & 3 (so it takes the default 'Y').  At Step 3, the periods just keep going so after 10 lines, I CTRL-C to quit.

Should I be using something else for the gateway?

 

Link to comment
Share on other sites

Watching the lights, I get orange (left light). When WP6 is applying the settings, the blue light (middle light) flashes and then goes steady.  For a very brief moment, I get an IP, but three seconds later, only the orange light is on and then 5-10 seconds,  no light.  Like its rebooting. 

Link to comment
Share on other sites

  • 1 month later...

This is how I got mine to work...

The Tetra is getting power from the AC adapter and is connected to my laptop via USB cables. 

When I run the script, I select [M]anual Setup. It's very much like the Guided in where it will ask you which interface is your Pineapple, which interface is your computer, and enter in your default gateway, which would be your computer's gateway, not the Tetra. In your case... 192.168.1.1

Then I select [C]onnect using saved settings.

I get the dots as if the Tetra is trying to connect. After a few dots, I'll unplug the USB cable from the Tetra and then plug it back in. 

This method works for me. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...