Jump to content

Recommended Posts

Hello guys,
First of all I want to say hi as I'm new to forum and WP. I also want to mention that I looked for the help in other topics but unfortunately was unable to overcome my issue.

I have a problem with connection sharing (I have access to internet, however nano does not - impossible to load bulletins). I used the script and it worked the first time. After I left nano scanning for a few minutes the connection was gone. Client mode works fine. Using the script again did not help. Adding new default routes to Kali did not help. Factory rested did't as well. I don't know how to resolve this...

My system info: 
Kali Rolling edition (not vm)
nano: v 2.5.2
script: wp6.sh

route on kali outputs:

Destination        Gateway        Genmask            Flags    Metric    Ref    Use    Iface
default                _gateway        0.0.0.0                UG         600         0      0         wlan0
10.0.0.0              0.0.0.0            255.255.255.0    U           600         0      0         wlan0
172.16.42.0       0.0.0.0            255.255.255.0    U           100 .       0      0         wlan0

ip route:

default via 10.0.0.1 dev wlan0 proto dhcp metric 600
10.0.0.0/24 dev wlan0 proto kernel scope link src 10.0.0.11 metric 600
172.16.42.0/24 dev eth1 proto kernel scope link src 172.16.42.109 metric 100

 

Wp6.sh configuration:
 

Saved Settings: Share Internet connection from wlan0
to WiFi Pineapple at eth1 through default gateway 10.0.0.1


(nano is indeed on eth1) ifconfig on eth1:
 

flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 172.16.42.109 netmask 255.255.255.0 broadcast 172.16.42.255
  (...)


also from management page:
Networking tab > route 
 

Kernel IP routing table
Destination 	Gateway			Genmask			Flags	Metric	Ref		Use	Iface
default			172.16.42.42	0.0.0.0			UG		0		0		0	br-lan
172.16.42.0		*				255.255.255.0	U		0		0		0	br-lan

 

"upadte route" shows in grey:
172.16.42.42


Please help me deal with this...
and sorry if something's stupid happening, I'm still a learner. let me know if more data is needed. Thanks!

 

Share this post


Link to post
Share on other sites

Okay, so just for the other people with this problem: It was caused by wrong auto-configuration of route nano was listening on. Going to networking tab and setting the default route to 172.16.41.109 solved the problem. Just make sure that in Kerner IP routing table in nano management networking tab you have the same route as your os outputs on "ip route" command (eth1 (or whichever you use) src value)
Hope this helps someone

 

thx to Poshmagicode

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...