Jump to content

http://172.16.42.1:1471 is unreachable


Mikelcrash
 Share

Recommended Posts

Good evening,

I just have connected my today got Pineapple Tetra to my pc with the y-usb-cable and connected it with the power-cable.
When typing

ifconfig

I'll get information about three ethernet cards eth0, eth1 and eth2 but no eth29 and noone has the IP 172.16.42.1.

In my browser I can't reach the http://172.16.42.1:1471 , too anyhow. What could be wrong here and how could I repair it.
Before I've downloaded the recommended firmware "upgrade-2.5.1.bin. To be able to execute it I switched the rights to 744. Than tried to execute it

./upgrade-2.5.2.bin
sh: 7: ./upgrade-2.5.2.bin: Exec format error

and this also didn't work.

Tried to execute it as root and got this

bash: ./upgrade-2.5.2.bin: Kann die Binärdatei nicht ausführen: Fehler im Format der Programmdatei

This means, that there is a problem with the format of the .bin.

Has anybody an idea, how to get this pineapple to work?

TIA

Mikel

Link to comment
Share on other sites

Hi,

You will only get one new Ethernet interface when you connect via the micro-USB port, labelled "Ethernet". Make sure your computers networking configuration isn't getting in the way of gaining an IP via the Pineapple on that micro-USB port. Hinting at what the LEDs are doing on the device would give more information.

Regarding the upgrade-2.5.2.bin - You don't run that on your computer, it is not an executable binary and there is nothing wrong with the format. It is used to update the device, which should be done via the Web Interface when you get to it and give the Pineapple an internet connection, or, by copying the file to the WiFi Pineapple's /tmp/ folder and executing over SSH the following:

sysupgrade -n /tmp/upgrade-2.5.2.bin

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...