Jump to content

Kali Linux - Issue with aireplay-ng

Micheal John

Recommended Posts

I am using Kali Linux in Virtual Box and using Realtek RTL8812AU chipset USB Wireless Adapter which supports both 2.4 & 5 Ghz.

I have successfully enabled the wireless adapter to monitor mode.

Enable wireless adapter to monitoring mode:
ifconfig wlan0 down
airmon-ng check kill
airmon-ng start wlan0
ifconfig wlan0 up


Now there are 2 issues;

Issue 1:

When I am using below airodump-ng command, sometimes all the 2.4 Ghz clients/devices are listed successfully. Sometimes, it is not listing the clients/devices, quite strange. I need to poweroff the Kali Linux in Virual Box and trying will work for the first time, then again not listing anything after second time.


Also, I noticed my access point is at channel 151 and sometimes the channel scanning not moving greater than 12-15, which may be the issue in detecting it.

Sometimes, the scanning goes beyond channel 170, but failed to list the AP which running at 151.
It is very annoying to poweroff each time and test it. Any advice on the fix.

airodump-ng wlan0


I am also trying to use below command to get the 5Ghz devices and it is listing but the same issue highlighted above exists for this.

airodump-ng --band a wlan0

Issue 2:
I am trying to test the deauthentication attack using aireplay-ng.

  1. I have enabled the wireless adpater to monitoring mode
  2. Run airodump-ng in the background

airodump-ng --bssid xx:xx:xx:xx:xx:xx --channel 151 wlan0
bssid --> access point bssid

  1. aireplay-ng -0 10 -a xx:xx:xx:xx:xx:xx -c yy:yy:yy:yy:yy:yy wlan0

xx --> access point bssid
yy --> client bssid which I wants to disconnect from network

Always I am getting the message as bssid not found in the channel xx.


I have tried to set the wireless adapter channel to the access point channel id, as suggested in some other thread as follows and that also not working.

iwconfig wlan0 channel 151

access point is at channel 151 and tried to set manually for the wireless adapter .

Link to comment
Share on other sites

I doubt its a driver issue with kali. Its fully loaded with wifi adapter firmware. But I guess upgrade for fun.


maybe a virtual box driver issue, check for updates. My opinion, a bootable kali usb or dual boot with internal ssd. 


Try other wifi adapters.


Install kali. Change to gnome-shell and its a slick operating system...


Or I run linux mint19 on all my machines and I just install all thools I want from kali

Edited by i8igmac
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...