Jump to content
nickelz34

rtl8812au driver-I want to pull my hair out !

Recommended Posts

Ok so i understand this driver is a frankenstein ( correct me if im wrong ) . If I read correctly, there is parts of other drivers that were taken and worked together to form what we have now over time, in order to get monitor mode and packet injection etc?

So like some of you have probably seen, searching here and on the web, it seems that there is definitely no shortage of users with issues relating to this driver as well . Some are legitimate issues and others are vast amounts of user errors during driver installs etc.


I originally ordered the bigger brother that has 4 antennas : https://www.amazon.com/Alfa-AC1900-WiFi-Adapter-Long-Range/dp/B01MZD7Z76

BUT LOL, of course (story of my life)..... Instead of getting that adapter the seller sent me this:

ALPHA AWUS036ACH wifi adapter : https://www.amazon.com/Alfa-Long-Range-Dual-Band-Wireless-External/dp/B00VEEBOPG

Now this sucker took over a week to get to me from canada, so i decided to keep it instead of waiting forever to get the other one. I started to look over the info to install it on kali and believe i originally used this repo ( https://github.com/kimocoder/rtl8812au ) . I thought the card was working fine and think i ran into trouble when i updated my kali linux distro (maybe something changed?).

So i searched and tried to find the driver again but i think i installed a differant repo (fork) of the rtl8812au . After i ran into more problems and more searching and different driver installs . I am now scratching my head wondering did these problems happen on the original driver repo i used ( https://github.com/kimocoder/rtl8812au) ?

Maybe because i had not used certain functions, i just didnt notice something that wasnt right ?


So my questions are:

What is the recommended install method for this driver?

Which driver should we be using ?

What is the current working functions and what does not work ?

What is the best way to totally remove the past remnants of installs for this driver ? I tried dkms installs and also manually compiled the driver different times . After removing everything i can find if i run

Code: [Select]
modprobe -c

i can still find several lines that say 8812au or 88xxau . they dont appear to actually be loaded or in use .


--------------------
Things I ran into
--------------------

- Ran into problems where i would try to host a fake access point but also set aireplay-ng to deauth in a different terminal

- Had issues when airodump-ng was ran it would take forever to populate wireless networks or signals would be horrible or lots of clients would not be associated

- Tried to use fluxion instead since it was automated but if i was trying to deauth/jam clients on same adapter that i also chose to be the fake access point it would just sit there and never start the access point. If i chose my laptops internal card for jamming and set the awus036ach for the access point it seemed to work. The access point showed up on my phone and if i clicked connect i did get the option to goto fake login page (did not try to enter password) .

- Before fluxion i also tried airgeddon which i thought worked with the original driver using the evil twin access point, but im not sure bc i loaded it other day and noticed in the yellow text terminal on top left it said AP-Disabled or Not enabled i believe . So i may have thought it was working at first and overlooked that area .

Share this post


Link to post
Share on other sites

Hello there, I have been having the same driver problems with my AWUS036ACH... 

Running Kali and Parrot on VM it would disconnect after a while in monitor mode( Windows sound of disconnection), after some research I got it to run with a script in this forum

It doesn't disconnect anymore but stops working sometimes, the blue LED is on and it works with wifite and airodump... But I cannot get it to run with airgeddon thought... Something is wrong, I would like to have it working alongside my Tplink in order to perform evil twin attacks.

Share this post


Link to post
Share on other sites

I have bought the same wifi device i am facing the same problem as you........ after many hours searching the internet it turns out that this device is useless if you want to use it to do evil twin i can say that it will never work unless someone else confirm the opposite.

I managed to install the driver on kali linux on virtual box, i managed to run the monitor mode and the injection is working with airdump and aireplay but here is the big problem.

I couldn't make it work with airgeddon or fluxion both of those apps can't see the device .

if someone out there know any solution for this problem please let us know. 

Share this post


Link to post
Share on other sites

I have had success using aircrack-ng's driver on their github page. I have only recently found this and have only used basic monitor mode functions, so I cannot say if it will do everything you want but here's the link anyway!

https://github.com/aircrack-ng/rtl8812au

And for those who want to use airodump-ng remember to use the

--band

option so that it scans outside the default 2.4GHz range.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...