Jump to content

Over-current condition after update


Recommended Posts

Hello, my bash bunny stopped working , with no LED at all when I plug it.

I can see that the dmesg command on Linux say :

[23134.085746] usb usb2-port3: over-current condition
[23134.175825] usb 1-1-port3: over-current condition


What I did before:

It happened shortly after the 1.5 firmware upgrade. I unplugged it, then plugged in again, and manage to copy some payloads and files in it.

Everything worked fine at this time, and suddenly (maybe ten minutes after the copy ? I don't really know) It stopped.

Now I have this  over current condition message when I try to plug it on several OS/Computers.


Any Idea on this problem ? Maybe something I could try, like a Hard Reset ?

Link to comment
Share on other sites

I tried, but the first step don't work.


1. Plug in the Bash Bunny and unplug it immediately when the initial green LED turns off

The LED never turn on when I plug it.

Even worse, If I plug it on a Windows 10, every USB ports on my computer are instantly disabled.

Looks like a short-circuit maybe ?

Link to comment
Share on other sites

That right there is when you email Hak5 support at their shop.  That definitely is a hardware issue.  Your BB is shorting.  Either something fried inside of it (maybe bad solder connection, not trying to say the guys at Hak5 cannot solder..just anything can happen) or literally the firmware flash has somehow set the current draw on the chip the BB uses too high.  I would be afraid to even plug that into USB power because if it is drawing too much it will definitely get your BB smoking but the Hak5 folks can confirm that.  Also, check and make sure there isn't any debris in the USB connector of the BB that maybe shorting out some pins to each other or the the USB shield.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...