Jump to content
Hak5 Forums
KR1$71QN

Tetra issues after firmware upgrade

Recommended Posts

Hello everyone!

Recently I have upgraded to the latest firmware, however they are several issues I have encountered.

  • Tetra freezes when USB WiFi card is plugged into (TL-WN821N 300Mbps used) outcome > requires full reboot
  • Tetra freezes when RJ45 plugged in in order to share internet connection outcome > requires full reboot
  • Evil portal sometime does/not handle function Success instead shows "You have not been authorised" outcome > however client is successfully authorised prior checking the list 
  • Doing Recon scans sometime gives unknown error outcome > requires full reboot

Any suggestion/recommendations on how to resolve that from the support team please?

Share this post


Link to post
Share on other sites

Hi, I am new here, but not new to networking/pen-testing/incident response/forensics.

Just received my new Tetra and upgraded to latest firmware, I am getting very similar issues with USB WiFi, sometimes the Tetra will recognize adapter on WLAN2 and connect, other times it will not see the card until numerous reboots/un-plugs.

Even when the adapter is recognized it might only stay up for 5-10 minutes.

I get the same recon errors...not every time.

And I am sick of the box freezing.

Tried the following adapters:

  • TL-WN821N
  • TL-WN722N
  • Numerous Alpha's etc.

So, I am now getting a "recommended" RT5370 chipset adapter from amazon to see if it at least clears the WLAN2 issue... could it be power drain ????

As for the other issues...I'm in 2 minds to send it all back for a refund, not what I expected .... And I haven't started with any modules yet!!!

Or... is an earlier firmware better ???

Share this post


Link to post
Share on other sites

I do believe the issues are due to firmware related, could it be power or resources drain, who knows?

Not an expert in the hardware of that particular device, but needs a serious attention and proper fix!

I believe the developers at Hak5 are going to get that fixed, because it is a great tool saving time, however needs some more computational power, if this does not happen soon moving back to terminal typo and other hardware equip.

Earlier firmware never gave me a failure or error in the Recon module.

Share this post


Link to post
Share on other sites

I was hoping to try this on-site for a client on Monday, I will re-flash with an earlier firmware, but TBH I might just revert back to something stable like you say... 2 alphas and a laptop 🙂

Share this post


Link to post
Share on other sites

Ok, dropped down a version (2.4.1) and got one of these off amazon, 

https://www.amazon.co.uk/dp/B01LYUWQZQ/ref=pe_1909131_77697121_tnp_email_TE_AMZLdp_1

So far no issues with Client WLAN dropping or any major stability issues, one or two operational issues still exist...but thats down to me to learn the modules correctly.

Hopefully on Monday I will now at least have a system that stays running :-).

 

 

 

Share this post


Link to post
Share on other sites

This was the firmware I've used before and had no problem with it. I am expecting the Hak5 engineering people to get all that fixed before adding new features, as a lot of people seem to have problems with the firmware. Lets give them a chance to see after the holidays what is going to be done regarding the issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×