Jump to content

Archived

This topic is now archived and is closed to further replies.

Recommended Posts

First thing first

(1)

Opening Terminal and typing following command:-

"msfconsole"

 

and getting this output:-

Quote

Could not find i18n-0.7.0 in any of the sources
Run `bundle install` to install missing gems.

so i ran that command in terminal did't worked out

now after googling for 3 hrs i found many things which are here

1). i should run "bundle install"  in this directory /usr/share/metasploit-framework

after that i'm getting this error
 

Quote

 

 

Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.


Fetching gem metadata from https://rubygems.org/......
Using rake 11.2.2
Using i18n 0.7.0
Fetching json 1.8.3
Installing json 1.8.3 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/var/lib/gems/2.5.0/gems/json-1.8.3/ext/json/ext/generator
/usr/bin/ruby2.5 -r ./siteconf20181130-20426-on0hxl.rb extconf.rb
creating Makefile

current directory: /var/lib/gems/2.5.0/gems/json-1.8.3/ext/json/ext/generator
make "DESTDIR=" clean

current directory: /var/lib/gems/2.5.0/gems/json-1.8.3/ext/json/ext/generator
make "DESTDIR="
compiling generator.c
generator.c: In function ‘generate_json’:
generator.c:861:25: error: ‘rb_cFixnum’ undeclared (first use in this function)
     } else if (klass == rb_cFixnum) {
                         ^~~~~~~~~~
generator.c:861:25: note: each undeclared identifier is reported only once for
each function it appears in
generator.c:863:25: error: ‘rb_cBignum’ undeclared (first use in this function)
     } else if (klass == rb_cBignum) {
                         ^~~~~~~~~~
Makefile:242: recipe for target 'generator.o' failed
make: *** [generator.o] Error 1

make failed, exit code 2

Gem files will remain installed in /var/lib/gems/2.5.0/gems/json-1.8.3 for
inspection.
Results logged to
/var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/json-1.8.3/gem_make.out

An error occurred while installing json (1.8.3), and Bundler cannot
continue.
Make sure that `gem install json -v '1.8.3' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  metasploit-framework was resolved to 4.12.22, which depends on
    metasploit-credential was resolved to 2.0.3, which depends on
      metasploit_data_models was resolved to 2.0.0, which depends on
        metasploit-concern was resolved to 2.0.1, which depends on
          railties was resolved to 4.2.7.1, which depends on
            actionpack was resolved to 4.2.7.1, which depends on
              actionview was resolved to 4.2.7.1, which depends on
                rails-dom-testing was resolved to 1.0.7, which depends on
rails-deprecated_sanitizer was resolved to 1.0.3, which
depends on
                    activesupport was resolved to 4.2.7.1, which depends on
                      json

 

Now again after doing research i found that i've to update jason so ran following command

"gem install json -v1.8.3"

 

which gave me output as:-

Quote

 

Building native extensions. This could take a while...
ERROR:  Error installing json:
    ERROR: Failed to build gem native extension.

    current directory: /var/lib/gems/2.5.0/gems/json-1.8.3/ext/json/ext/generator
/usr/bin/ruby2.5 -r ./siteconf20181130-21842-ryyt3r.rb extconf.rb
creating Makefile

current directory: /var/lib/gems/2.5.0/gems/json-1.8.3/ext/json/ext/generator
make "DESTDIR=" clean

current directory: /var/lib/gems/2.5.0/gems/json-1.8.3/ext/json/ext/generator
make "DESTDIR="
compiling generator.c
generator.c: In function ‘generate_json’:
generator.c:861:25: error: ‘rb_cFixnum’ undeclared (first use in this function)
     } else if (klass == rb_cFixnum) {
                         ^~~~~~~~~~
generator.c:861:25: note: each undeclared identifier is reported only once for each function it appears in
generator.c:863:25: error: ‘rb_cBignum’ undeclared (first use in this function)
     } else if (klass == rb_cBignum) {
                         ^~~~~~~~~~
Makefile:242: recipe for target 'generator.o' failed
make: *** [generator.o] Error 1

make failed, exit code 2

Gem files will remain installed in /var/lib/gems/2.5.0/gems/json-1.8.3 for inspection.
Results logged to /var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/json-1.8.3/gem_make.out

 

 

 

 

Please guys help me out here i can't open msfconsole.!😥

 

 

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...