Jump to content
x77x

Setting up a SD Card on the NANO using Windows 10

Recommended Posts

Whats up everyone so Im somewhat new to the Wifi Nano and Command Prompt. So that being said I need help mounting a sd card on the Wifi Nano in Command Prompt or if there is a way to do on the Nano web interface. Any help would be great.

Share this post


Link to post
Share on other sites

Okay so this is how you mount a sd card on the Nano

login to the web ui.

in the advanced setting tab scroll down to usb

click on the arrow right beside the usb then click format sd card

Share this post


Link to post
Share on other sites

This can't be right - and I'm definitely having problems generating consistent results.  Surely, I don't have to format the SD card every time I want to mount it, right?

I've got a 32GB uSD card in my nano - and have 'formatted' it multiple times - and, exactly ONE time, it then showed up (under the Resources window).  Then I went about downloading and installing modules onto it - and then rebooted, and... it's gone.

There's GOT to be a way to mount it (if not via the web console, then simply via the CLI with # mount /dev/sda1 or ...

I think I must be missing something as it pertains to fstab (and the "Save Fstab" button in the web console).  I'm happy to RTFM, if someone can point me in the right direction??

 

Happy Friday!

Share this post


Link to post
Share on other sites

Bizarre.  Now, it has showed up two times:  I pulled the uSD from the nano (after countless attempts to format it from the web console, and even trying my hand at this gist:

https://gist.github.com/kbeflo/8c85c084e9c5ae86b3367716a463e793

(for the record - it didn't work for me either).  I tried stepping through the commands, one at a time, by hand... and still no dice.

So, finally, I pull the card, put it in a reader and plug it into the Mac.  Mac declares it 'unreadable', opens disk utility, and allows me to format it (I selected MS-DOS (FAT), assuming this would provide the greatest interoperability).

Returned the SD card to the Nano, powered it up, and... Voila!  The SD card was there.  I did a 'Save Fstab' in the console UI, and then proceded to download and install a handful (okay, perhaps two handfuls) of modules and installed them to the SD card successfully.  Eventually powered down the device... and now, a few hours later - upon reboot... no /dev/sdb anymore??

I'm obviously doing something wrong - as this just can't be this hard!

Thanks for any assistance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×