Jump to content
Hak5 Forums
ryo886

aireplay-ng --deauth not working

Recommended Posts

When I run the deauth-attack with aireplay, but still don't find any handshake. Then what mean  under massage (code 7)?

18:32:26 Sending 64 directed DeAuth (code 7)STMAC: [F8:1E:DF:31:C3:4B] [ 0| 0 ACKs]

18:32:26 Sending 64 directed DeAuth (code 7) STMAC: [F8:1E:DF:31:C3:4B] [ 0| 1 ACKs]

Share this post


Link to post
Share on other sites

Im have some probs with aireplay-ng 2 like getting it to run. Old versions no problem. might need to roll back to prev version.

Share this post


Link to post
Share on other sites

The code is a reason for deauthentication.

https://www.cisco.com/assets/sol/sb/WAP371_Emulators/WAP371_Emulator_v1-0-1-3/help/Apx_ReasonCodes2.html

I don't know the full context so I can only throw some guesses about what could have gone wrong:

1. You are probably too far from the client (check the packets captured, for every packet sent to the client you should see an ack packet sent back in response);

2. You de-authed one of the clients but it has not re-associated again or you are not capturing the association;

3. You trying to send broadcast de-auth requests instead of targeting an associated client;

4. Your wireless card does not support packet injection or there's a  problem with the drivers/software.

Share this post


Link to post
Share on other sites

I also forgot to mention that a lot of vendors are now switching to protected management frames so deauthing only works case by case now.

I will do a separate post about capturing PMKIDs for cracking WPA2 keys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×