Jump to content

Recommended Posts

I can't connect to my wifi pineapple nano.  I was able to connect to it before but I was experiencing some problems so I decided to do a firmware recovery.  I followed the instructions:

Next, follow these steps to access the recovery web interface and update the firmware.

  • Unplug the WiFi Pineapple completely from all power sources.
  • Begin holding the RESET button on the device.
  • With the RESET button held, power on the device.
  • Continue holding the RESET button for 10 seconds, then release.
    • NANO: The blue LED will remain solid
    • TETRA: The yellow LED will remain solid
  • Connect the host PC to the WiFi Pineapple via the USB Ethernet Port
    • NANO: The male USB A plug
    • TETRA: The Micro USB port labeled ETH
  • From the host PC, configure a static IP address on the WiFi Pineapple facing Ethernet interface to 192.168.1.2 with netmask 255.255.255.0
    • For example, in Linux run ifconfig eth1 192.168.1.2 netmask 255.255.255.0 up (where eth1 is the interface name of the WiFi Pineapple).
  • From the host PC, browse to http://192.168.1.1
  • Click Choose File and select the factory firmware image downloaded above.
  • Click Update Firmware.
  • This process will take several minutes. Do not interrupt the power supply while the firmware is updating. Once complete, the WiFi Pineapple will restart.
  • Reset the the WiFi Pineapple facing USB Ethernet interface back to DHCP or 172.16.42.42 with netmask 255.255.255.0

But when I try to connect to it via 192.168.1.1 it goes to my router login.  Please Help.  What am I doing wrong?

Link to post
Share on other sites
1 minute ago, Kook said:

But when I try to connect to it via 192.168.1.1 it goes to my router login.  Please Help.  What am I doing wrong? 

Just disconnect from your wifi/router. The pineapple defaults to 192.168.1.1 also so there is most likely a conflict. Disconnect and try again.

Link to post
Share on other sites
3 minutes ago, Kook said:

Do i have to set the wifi pineapple nano to 192.168.1.2 or can it be some other address?

the pineapple will take 192.168.1.1 so your laptop/pc would need to be manually set to 192.168.1.2 for example.

Link to post
Share on other sites

So I tried setting my laptop wifi adapter to 192.168.1.2 and the nano to 192.168.1.1 and that didn't work.  Also I disabled my laptop wifi and set the nano to 192.168.1.2 per firmware recovery instructions and then tried to go to 192.168.1.1 on my browser and nothing.  I can ping 192.168.1.2 but not 192.168.1.1 

I get the message: 

Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.2: Destination host unreachable.
Reply from 192.168.1.2: Destination host unreachable.
Request timed out.
Reply from 192.168.1.2: Destination host unreachable.

Ping statistics for 192.168.1.1:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

Link to post
Share on other sites
1 minute ago, Kook said:

I unplugged pressed and held button as I inserted back into my laptop and released the button 10 seconds after it was plugged in.

OK, if done correctly then it should be in uboot recovery mode. the wifi pineapple nano will automatically take the IP of 192.168.1.1 when in this mode.

Ignore your wifi adapter settings your not using it so don't change them.

The adapter that shows up as connected (on ubuntu its USB Ethernet) on your laptop will need to have its IPv4 address manually changed to 192.168.1.2 with a subnet of 255.255.255.0. save and exit. You may need to disable this interface and re enable it for those changes to take effect, on Ubuntu i use the interface switch quickly off and on and its done.

Once done you should be able to browse to http//192.168.1.1 to upload the factory version of the firmware (not the upgrade file) and start ythe flash process.

Link to post
Share on other sites

Ok.  Finally it worked.  I disabled my wifi on my laptop and reset the pineapple again and bam.  I tried that 2 times before but I guess my laptop adapter was enabled and caused some sort of conflict.  Thanks for the speedy replies.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...