Jump to content
DARK PARK

why ettercap not working ?

Recommended Posts

Hello , i bought new Wifi Pineapple NANO and i i've tried to install Ettercap module but i can not run it , and there is no log to check what is going on . 

 

is there any way to apply MITM attack on public network without forcing the clients to connect to my own evil AP , i want to spoof ARP and tcpdump all the traffic in nano sd.

 

 

Thanks

Share this post


Link to post
Share on other sites

Ettercap does work

ln -s /usr/lib/libpcap.so /usr/lib/libpcap.so.1.3     #if this exists already ignore
opkg update
opkg install ettercap

 

Edited by Just_a_User
  • Upvote 1

Share this post


Link to post
Share on other sites

 

1 hour ago, Just_a_User said:

Ettercap does work


ln -s /usr/lib/libpcap.so /usr/lib/libpcap.so.1.3     #if this exists already ignore
opkg update
opkg install ettercap

 

i've installed ettercap but not running , when i click start it shows me starting then back again to start 

Screen_Shot_2018_09_11_at_2_52_25_PM.png

 

Screen_Shot_2018_09_11_at_2_52_45_PM.png

Share this post


Link to post
Share on other sites

I am unsure whats going on with ettercap -i option with arp i get the same maybe we do something wrong. its not a tool i use much. But strangely  I can specify interface on other functions e.g.

root@Pineapple:~# ettercap -T -M arp:remote // -i eth0

ettercap 0.8.2 copyright 2001-2015 Ettercap Development Team

Listening on:
  eth0 -> 00:13:37:A5:86:0D

either way I forget we have dsniff suite installed, maybe use arpspoof instead?

Edited by Just_a_User

Share this post


Link to post
Share on other sites
17 hours ago, Just_a_User said:

I am unsure whats going on with ettercap -i option with arp i get the same maybe we do something wrong. its not a tool i use much. But strangely  I can specify interface on other functions e.g.


root@Pineapple:~# ettercap -T -M arp:remote // -i eth0

ettercap 0.8.2 copyright 2001-2015 Ettercap Development Team

Listening on:
  eth0 -> 00:13:37:A5:86:0D

either way I forget we have dsniff suite installed, maybe use arpspoof instead?

about the Ettercap , the problem i can not use eth0 interface because im connected by using wlan1 so there is no point of using eth0 as i understand , about arpsoof not yet , i've to test it 

 

 

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...