Jump to content

Curl is not installed


mimo
 Share

Recommended Posts

I wanted to make a curl request with the latest version (2.3.2), but it seems not to be installed. phpinfo() returns me that php was compiled --without-curl. I tried to install curl, but I found no command that worked...

"opkg info curl" returns nothing and running "opkg install curl" says that the package does not exists (I never worked with Kali so I don't know if it's the right way to install a package). Is maybe my image broken or do I need manual steps to install it?

Link to comment
Share on other sites

 

1 hour ago, mimo said:

I found no command that worked...

You had it but missed the update first - Make sure the pineapple has internet and try

opkg update
opkg install curl

# or nstall to sd card with

opkg install curl --dest sd

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...