Jump to content

Nano client mode VERY SLOW


cheeto
 Share

Recommended Posts

Hi folks,

 

I'm having the following issue with my nano.

I'm currently using it in CLIENT mode.

So I feed it internet thru my wifi router connection.

When a client connects to the nano, the internet connection is REALLY SLOW.  MAX download speed is 5mb.

If I connect directly to my WIFI i get 50mb.  (HUGE DIFFERENCE)

 

Test 2:

Instead of feeding the Nano internet thu my Wifi network, I'm feeding it from my cell phone's hotspot.

Again, the nano top download speed is 2mb

If i connect my laptop to my phone's hotspot I get 10mb. (HUGE DIFFERENCE)

 

Ok, so at this point there is an obvious problem with my nano.

 

So I RESET it and nothing changed. 

I downgraded to firmware version 2.1.0 and nothing changed.

I swapped antennas and again no change.

I changed power source from battery to a Samsung phone charger.  no change.

 

Can someone PLEASE give me a suggestion?  

 

Thanks!

Edited by cheeto
Link to comment
Share on other sites

Your doing a wifi repeater?  Wlan1 connects to your router(internet source) wlan2 broadcast a wifi hotspot for your devices to connect?

 

I had intense conversation about this kind of poor quality wifi a few weeks ago on the forums. I have a lot of experience with this and there are some tweaks and suggestions I have for you. I see this kind of post on the forums with no resolution related to poor throughput speeds. I'm happy to share my configuration files and knowledge but first I need more information and you to setup a proper test environment.

 

You need to test the speeds with your local devices First. try to achieve max throughput speeds or speeds equal to 50mb from the nano to your labtop or nano to android phone...

 

The best way to do this is with iperf installed on the nano and another device. You can install iperf on a android. There are instructions online for installation of iperf for openwrt.

 

once you answer the first question at the top and install Iperf on multiple devices I can began with instructions and technical details on why this issue you experience exist.

 

If you fail to install iperf on the nano ill provide a alternative solution.

Link to comment
Share on other sites

Hi i8igmac and many thanks for getting back to me!!  That was really fast.

At this time at work however, before leaving home I did some more experimenting and I think I’m getting somewhere.

1)      I’m connecting my nano to my wifi network with WLAN2.   My USB radio is an “Alfa” that I also purchased from Hak5.   I also tried an alternative usb radio that was also purchased from “Hak5” & in both cases the speed was EXTREEMLY SLOW.

 

2)      I disconnected my usb radio on my Nano and connected to my wifi network & it works very good when connecting to my router with WLAN1.  The speed seems to be normal again.

*If I try to connect with wlan1 to my router while having a usb radio (Wlan2) connected to the  Nano, the speed is VERY SLOW.

 

Conclusion: My Nano’s problem is clearly WLAN2.  Is there anything I can do to fix it?

 

3)      Regarding Iperf, I went ahead and installed it on my phone.   I’m going to look into how to install it on my nano.   If it’s on Github, I think I’ll be able to install it.  Not too diffent than adding files on Kali Linux.

br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:8F:9E:44
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1430 errors:0 dropped:75 overruns:0 frame:0
          TX packets:1653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:268924 (262.6 KiB)  TX bytes:1393735 (1.3 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:8F:9E:44
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:25 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2213 (2.1 KiB)  TX bytes:2213 (2.1 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:8F:6F:93
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1457 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1859 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:296100 (289.1 KiB)  TX bytes:1454714 (1.3 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:8F:6F:93
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:217 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:28903 (28.2 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:C0:CA:8F:87:CF
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan2     Link encap:Ethernet  HWaddr 00:13:EF:C2:09:C3
          inet addr:192.168.1.125  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:923 errors:0 dropped:9 overruns:0 frame:0
          TX packets:877 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:392658 (383.4 KiB)  TX bytes:206596 (201.7 KiB)

 

Thanks again

 

 

 

 

nano.PNG

Link to comment
Share on other sites

Here you go:

 

 

 

root@Pineapple:~# iwconfig wlan2
wlan2     IEEE 802.11bgn  ESSID:"Linksys"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 50:C7:BF:DE:C6:5B
          Bit Rate=1 Mb/s   Tx-Power=30 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=53/70  Signal level=-57 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2431  Invalid misc:158   Missed beacon:0


root@Pineapple:~# iwconfig wlan1
wlan1     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
 

Link to comment
Share on other sites

Excessive amounts of retries. I checked my setup has been running for a week and mine has 105  excessive retries with long distance. 

 

can you change the hotspot to 80211b/g. disable wireless N

 

Also post a quick airodump. 

 

What alfa card is this. Atheros?

Link to comment
Share on other sites

OK I changed the hotspot like you said and disabled wireless n

 

Here are the results oF wlan 2

root@Pineapple:~# iwconfig wlan2
wlan2     IEEE 802.11bgn  ESSID:"Linksys"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 50:C7:BF:DE:C6:5B
          Bit Rate=1 Mb/s   Tx-Power=30 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:15  Invalid misc:12   Missed beacon:0

 

I did a speed test and got 8.5mb    It is a little better but still lagging.   Again, Wlan2 is clearly the issue.

 

thanks

 

 

 

 

Link to comment
Share on other sites

i did a third est and i got:

 

root@Pineapple:~# iwconfig wlan2
wlan2     IEEE 802.11bgn  ESSID:"Linksys"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 50:C7:BF:DE:C6:5B
          Bit Rate=1 Mb/s   Tx-Power=30 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=57/70  Signal level=-53 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:5037  Invalid misc:143   Missed beacon:0

 

speed test results: 4.2mb

Link to comment
Share on other sites

TEST 4:

I connected my nano's client mode to my Cell phones OPEN (no password) wifi network and it still has problems:

 

root@Pineapple:~# iwconfig wlan2
wlan2     IEEE 802.11bgn  ESSID:"Admin"
          Mode:Managed  Frequency:2.412 GHz  Access Point: D0:31:69:17:3C:77
          Bit Rate=1 Mb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=65/70  Signal level=-45 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:59  Invalid misc:70   Missed beacon:0
 

 Still very slow.  ?

Link to comment
Share on other sites

Occasionally I have had to do some testing and found it useful to do speed tests from the pineapple itself and then from a pineapple client to check for differences.

I found you can run https://github.com/sivel/speedtest-cli  on the pineapples as long as you use the  --no-pre-allocate option. Requires pip

I have found that sometimes i get good speeds from the pineapple but less on clients. maybe worth a try.

Link to comment
Share on other sites

 

Thanks for jumping in "Just_a_User"

Look, I understand that my nano's speed could be slower, but this is pretty bad.

 

The picture describes everything. These are the results i get when using WLAN1.   When using wlan2 it's even slower.

 

nano4.png

Edited by cheeto
Link to comment
Share on other sites

There is a bug in wireless n and some linux drivers.  I cant find a working example for you to enable mode b/g with hostapd_cli.

 

You should also disable ipv6.

 

If you can post airodump results. We could also see if your operating on the best channel for your wifi environment.

 

 

This is a command I use to test internet download speeds.

Wget -O /dev/null testmy.net/dl-50000

 

Wavemon is also a great tool for monitoring wifi signal.

 

But you should check your download speeds between the nano and a android phone with iperf. 

 

Run on the nano. iperf -s

Run on the phone. iperf -c 192.168.nano

after you make your changes then check iperf results again to see improvement.

 

My phone iperf shows 53.5 Mbits/s

  • Like 1
Link to comment
Share on other sites

I tried installing iperf but failed.   I used these commands:

apt-get install iperf
yum install iperf
emerge iperf

 

but nothing worked.

 I also tried:

root@Pineapple:~# /dev/null: No such file or directory
-ash: /dev/null:: not found

 

and didn't work as well.  ?   I guess it's a hardware issue.  I'll be forced to use WLAN1 instead of WLAN2.   This is too bad because I will not be able to benefit from PineAP.

 

Thanks

Link to comment
Share on other sites

2 hours ago, cheeto said:

I tried installing iperf but failed.   I used these commands:

apt-get install iperf
yum install iperf
emerge iperf

 

but nothing worked.

 I also tried:

root@Pineapple:~# /dev/null: No such file or directory
-ash: /dev/null:: not found

 

and didn't work as well.  ?   I guess it's a hardware issue.  I'll be forced to use WLAN1 instead of WLAN2.   This is too bad because I will not be able to benefit from PineAP.

 

Thanks

you can run iperf on a labtop and phone both connected to the nano. Its simply for testing throughput speeds.

 

https://superuser.com/questions/843198/changing-network-mode-to-n-only-in-openwrt

read the thread above. This might disable wireless n and enable g...

Not sure if its radio0 or radio1. So notice i put $$$. Maybe run the command on both radio0-1

uci get wireless.radio0.require_mode

uci get wireless.radio1.require_mode

uci set wireless.radio$$$.require_mode=g

uci commit

wifi

uci get wireless.radio$$$.require_mode

 

Edited by i8igmac
Link to comment
Share on other sites

Thanks but I'm still getting error after error while in putty mode:

 


root@Pineapple:~# uci get wireless.radio0.require_mode
uci: Entry not found
root@Pineapple:~# uci get wireless.radio1.require_mode
uci: Entry not found
root@Pineapple:~#

root@Pineapple:~# uci get wireless.radio0-1.require_mode
uci: Parse error
 

I think it's not recognizing the command.  Please keep in mind that i don't have iperf installed on my nano,   i do however have installed on my phone.

thanks

Link to comment
Share on other sites

2 hours ago, cheeto said:

Thanks but I'm still getting error after error while in putty mode:

 


root@Pineapple:~# uci get wireless.radio0.require_mode
uci: Entry not found
root@Pineapple:~# uci get wireless.radio1.require_mode
uci: Entry not found
root@Pineapple:~#

root@Pineapple:~# uci get wireless.radio0-1.require_mode
uci: Parse error
 

I think it's not recognizing the command.  Please keep in mind that i don't have iperf installed on my nano,   i do however have installed on my phone.

thanks

Cat /etc/config/wireless

post content plz

cat /etc/hostapd.conf

post content plz

uci show wireless

post content plz

 

maybe install like this

opkg install iperf

Edited by i8igmac
Link to comment
Share on other sites

thanks again for getting back to me.

Unfortunately "Cat /etc/config/wireless" doesn't work.

Is this normal?

thanks,

 

root@Pineapple:~# cat /etc/config/wireless
cat: can't open '/etc/config/wireless': No such file or directory
root@Pineapple:~#

nano1.thumb.PNG.5507a35d6dc1f9a6adc8dbab6f27b43b.PNG

Link to comment
Share on other sites

Thanks for jumping in Foxtrot.
I did the "opkg update" and that enabled me to run the cat command (cat /etc/config/wireless).
Unfortunately I couldn't run the 2nd cat command (cat /etc/hostapd.conf)

I was able to finally install "iperf"

Here is the "cat /etc/config/wireless" readings:
Thanks guys
 

root@Pineapple:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option maxassoc '100'
        option encryption 'none'
        option ssid 'TEST WiFi'
        option hidden '0'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Management'
        option encryption 'psk2+ccmp'
        option key 'pineapplesareyummy'
        option disabled '1'
        option hidden '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ehci-platform/usb1/1-1/1-1.1/1-1.1:1.0'
        option htmode 'HT20'

config wifi-iface
        option device 'radio1'
        option ifname 'wlan1'
        option mode 'sta'
        option network 'lan'
        option ssid '0'
        option encryption 'none'
        option key '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ehci-platform/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'

config wifi-iface
        option device 'radio2'
        option ifname 'wlan2'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Linksys'
        option encryption 'psk-mixed+ccmp+tkip'
        option key '20012010'

 

nano1.PNG

Edited by cheeto
Link to comment
Share on other sites

I see multiple devices running on channel 11. This typically will cause interference excessive retrys and packet loss..

 

Radio0 is running access point 'test wifi' on channel 11

radio2 is connected to linksys on channel 11

 

try changing radio0 to channel 1.

Edited by i8igmac
Link to comment
Share on other sites

Good observation!

 

Questions:

1) How could i change the radio (radio 0 and radio 2)  channels?

If I use WLAN 1 as WiFi Client Mode,  the Nano works much better.   But If i use Wlan1 as "client mode" I sacrifice my PineAP. 

 

Cheers and thanks!

Link to comment
Share on other sites

 

 

Wow, I thought you had a Nano.   You sure know a lot about it!! ?

airdump-ng wlan2 gave me this:

 CH  2 ][ Elapsed: 24 s ][ 2018-08-08 01:13

 BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID

 80:D4:A5:6B:B9:94   -1        0        2    0   3  -1   OPN              JOSUE RIVER PLATE
 02:22:E2:46:15:46   -1        9        0    0   6  54 . OPN              HPD110a.8E6B2E
 D0:31:69:17:3C:77  -34        2        0    0  11  260  WPA2 CCMP   PSK  Admin
 00:C0:CA:8F:6F:93  -38        4       48    0   7  260  OPN              BA WiFi
 50:C7:BF:DE:C6:5B  -54        1        1    0   1  260  WPA2 CCMP   PSK  Linksys
 14:D6:4D:E0:9B:FC  -67        9        0    0   6  260  WPA2 CCMP   PSK  iofi
 48:83:C7:BD:C8:CB  -72       15       17    0  11  260  WPA2 CCMP   PSK  Fibertel WiFi486 2.4GHz
 48:83:C7:8C:35:96  -74       26        0    0   1  260  WPA2 CCMP   PSK  Telecentro-3590
 48:83:C7:8D:F5:6E  -79        9        1    0   7  260  WPA2 CCMP   PSK  Telecentro-f568

 BSSID              STATION            PWR   Rate    Lost    Frames  Probe

 80:D4:A5:6B:B9:94  DC:71:44:4E:04:C1  -76    0 - 1e     0       10  JOSUE RIVER PLATE
 02:22:E2:46:15:46  80:C1:6E:8E:6B:2E  -76    0 - 1     59        9
 00:C0:CA:8F:6F:93  02:20:A6:85:A3:45  -34    0 - 0e   137       61
 50:C7:BF:DE:C6:5B  F0:03:8C:52:F7:B9  -60    0 - 1e     0        1
 50:C7:BF:DE:C6:5B  40:9C:28:A6:E8:D6  -66    0 -24      0        6
 48:83:C7:BD:C8:CB  30:63:6B:D3:6E:5F   -1    5e- 0      0       17
 48:83:C7:BD:C8:CB  94:71:AC:F8:4D:43  -76    0 - 1      8        4

 

 

 

Wlan1 results:

 CH  4 ][ Elapsed: 18 s ][ 2018-08-08 01:02

 BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID

 80:D4:A5:6B:B9:94   -1        0        2    0   3  -1   OPN              <length:  0>
 02:22:E2:46:15:46   -1        6        0    0   6  54 . OPN              HPD110a.8E6B2E
 00:C0:CA:8F:6F:93  -38        4       93    8   7  260  OPN              TEST WiFi
 D0:31:69:17:3C:77  -34        2       18    0  11  260  WPA2 CCMP   PSK  Admin
 50:C7:BF:DE:C6:5B  -47        2        1    0   1  260  WPA2 CCMP   PSK  Linksys
 14:D6:4D:E0:9B:FC  -70        5        0    0   6  260  WPA2 CCMP   PSK  iofi
 48:83:C7:BD:C8:CB  -74        9        0    0  11  260  WPA2 CCMP   PSK  Fibertel WiFi486 2.4GHz
 48:83:C7:8C:35:96  -76       16        0    0   1  260  WPA2 CCMP   PSK  Telecentro-3590
 48:83:C7:8D:F5:6E  -77       19        2    0   7  260  WPA2 CCMP   PSK  Telecentro-f568
 A8:6B:AD:91:7F:10  -81        2        0    0   6  260  OPN              HP-Print-10-LaserJet M12

 BSSID              STATION            PWR   Rate    Lost    Frames  Probe

 80:D4:A5:6B:B9:94  3C:17:10:14:46:BA  -76    0 - 1e     0        1
 80:D4:A5:6B:B9:94  DC:71:44:4E:04:C1  -74    0 - 1e     0        1
 80:D4:A5:6B:B9:94  B4:BF:F6:F5:DA:71  -74    0 - 1      0        2
 (not associated)   94:71:AC:F8:4D:43  -80    0 - 1      0        1
 02:22:E2:46:15:46  80:C1:6E:8E:6B:2E  -76    0 - 1     50        6
 00:C0:CA:8F:6F:93  02:20:A6:85:A3:45  -46    0 - 0e     0      109
 D0:31:69:17:3C:77  00:C0:CA:8F:87:CF   -1    0e- 0      0       18
 48:83:C7:8D:F5:6E  F0:D7:AA:45:96:87  -70    0 - 6      0        2
Link to comment
Share on other sites

I went ahead and did the "iw dev"

Here are the results:

root@Pineapple:~# iw dev
phy#2
        Interface wlan2
                ifindex 13
                wdev 0x200000005
                addr 00:13:ef:c2:09:c3
                type managed
                channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
                txpower 30.00 dBm
phy#1
        Interface wlan1
                ifindex 12
                wdev 0x100000003
                addr 00:c0:ca:8f:87:cf
                type managed
                txpower 20.00 dBm
phy#0
        Interface wlan0
                ifindex 7
                wdev 0x2
                addr 00:c0:ca:8f:6f:93
                ssid TEST WiFi
                type AP
                channel 7 (2442 MHz), width: 20 MHz, center1: 2442 MHz
                txpower 17.00 dBm
root@Pineapple:~#

 

The results you show are what I would call a typical 2.4 wifi environment. I mean typically congested 2.4ghz environment.

 

80211-frequency-channel-map.jpg

 

The wifi devices in your environment I see channels in use Are.

1, 3, 6 , 7 , 11, 9

for the best conditions you only want to see in use are channels 1,6,11... the picture I posted shows the proper channel spacing for these 3 channels do not over lap. Most devices will simply default on one of these 3 channels and newer device will scan the area and select one With less interference.

 

I see a ugly set of channels in use. 3, 7, 9

Notice how channel 3 is overlapping on channels 1-6? your internet source is sitting on channel 1 and your seeing interference bleeding in from packets floating around on channel 3. Your router is waisting time and resources trying to read packets that don't belong on the network.

 

Think of it like a set of hand held walkie-talkie radios. Your having a conversation with your friend on channel 1 but you hear another persons distorted conversation bleeding in from another channel... in wifi this is what causes packet drops, retries, or packet loss...

 

Your running wlan0 on channel 9. this needs to be changed to maybe channel 6 or 11

 

But this does not explain why your internal wifi card is performing better connecting to your internet source on channel 1. This could be due to better driver implementation or simply a better Wifi card.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...