Jump to content

How to log on to and open client network to set up WiFi Client Mode


C0ntr07
 Share

Recommended Posts

I am sure this is documented somewhere - I just can't find where.

At the client site where I am working their WAPs are all open. To connect you have to enter a username and password on a webpage when you first connect.

As much as I have tried, I just can't figure out how to do this.

How can I enter web-based credentials after connected to an access point?

Thanks in advance for the help.

Link to comment
Share on other sites

10 hours ago, _0NiTy said:

I believe this is the page you're looking for: https://www.wifipineapple.com/pages/setup#tetra

Thanks @_0NiTy for the quick reply.

Unfortunately, the link is for the basic set up. I've set up the TETRA and have been using it months. I have no trouble connecting to WIFI access points and performing successful MiTM activities.

The issue is once I have connected to the WIFI network, this client, as many do, require a user to sign in through a company website. This provides places to enter username and password credentials and in many situations, requires the review and acceptance of their user policy. The credentials and acceptance is required before networking access is provided.

I have no idea how to interact with the client webpage to enable network access.

Does anyone have a solution?

Link to comment
Share on other sites

32 minutes ago, C0ntr07 said:

Does anyone have a solution?

You can connect to your wifi pineapple management network, then complete the free wifi registration/acceptance stuff - it will usually think its the Tetra's MAC that has registered (and therefore allow its clients) but you will possibly have to repeat this after a time limit or inactivity. 

For registered Wifi it may be expecting a certain MAC/IP/Certs etc so may not accept the Tetra. I guess. Hope i understood your situation.

 

Edited by Just_a_User
Link to comment
Share on other sites

22 minutes ago, Just_a_User said:

... it may be expecting a certain MAC/IP/Certs etc ...

 

 

@Just_a_User thanks for the reply.

I think this very well might be the situation. I can't imagine there isn't a solution to this common configuration.

I know enough Linux to be dangerous. I spent a couple of days trying to figure out how to get a GUI in OpenWRT (I'm 99 44/100 % sure it can't). I tried to install a tiny browser in OpenWRT (I'm 99 44/100 % sure it can't).

What I don't know is what Linux commands can I use to interact with the access point to provide the credentials and provided the required acceptance? Maybe someone smarter than I (which is a large set) can write a script to do this. Any pen and vulnerability tester in the corporate / enterprise environment needs this capability. I'm a bit surprised it doesn't currently exist.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...