Jump to content
Draxiom

Storage not mounting on host

Recommended Posts

Hey all,

I have got my bb into a state that I can't seem to recover from and I was hoping for some help. Here's the scenario: I had just updated my bb using the bb updater on mac and confirmed the version number was up to date. Then, I was testing out the TARGET_OS and AUTO_ETHERNET flags (from this post: https://forums.hak5.org/topic/42465-release-bash-bunny-firmware-v15/?do=findComment&comment=301403) when the storage stopped mounting. It now does not mount on the host machine no matter what I have tried since. Here's what I have tried so far with no access to mounted drive from host:

  1. Switch to arming mode
  2. Simple payload with `ATTACKMODE STORAGE` as the only command on switch1 and switch2
  3. Ran firmware recovery/reset
  4. Manually loaded udisk.sh script (local mount works, still never shows on host)
    1. https://forums.hak5.org/topic/41051-canøt-mount-nandf-how-to-completely-restore/?do=findComment&comment=291815
  5. (re)formated udisk
  6. Added `ATTACKMODE SERIAL STORAGE` to /root/udisk/payloads/arming/payload.txt
  7. Tried to ics but could not get a connection to the outside world

I can still:

  1. screen into bb in arming mode and with `ATTACKMODE SERIAL` on either switch position
  2. manually mount the nandf partition using the udisk script
  3. Trigger the basic LED commands that first came with the bb
    1. since I ran recovery, I am no longer on the latest firmware

Note: I only have access to mac and linux. windows by vm only.

Any thoughts on how I can get the mass storage mounting on my host computer in arming mode?

Share this post


Link to post
Share on other sites

Update: I realized that I didn't try plugging it into my linux box and was able to get it to mount on that. Got it all updated through the linux updater and everything works normally... on my linux box. On my mac, the bb still is not mounting. So my solution is to get rid of my mac.

https://i.imgur.com/i3IfafU.gifv

Anybody have an idea for me to avoid this?

  • Like 1

Share this post


Link to post
Share on other sites

Update: *hangs head in shame* I restarted the mac, and it started mounting again. Carry on like nothing happened.

Yj6dB3Wh.jpg

  • Like 2

Share this post


Link to post
Share on other sites

it must be a mac thing

Share this post


Link to post
Share on other sites
9 hours ago, Draxiom said:

Anybody have an idea for me to avoid this?

hahaha the MAC USB killer payload worked!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...