Jump to content

Firmware 1.5 wont update


HoytMagnus
 Share

Recommended Posts

I just got a Bash Bunny and it is running firmware 1.3_267 and figured there is newer firmware for it , so like a good little computer user I should update. I have tried two different methods and both fail in the same way. First, I downloaded version 1.5_298 and copied to the root of the BB, rebooted the BB and I get a green then red/blue flashing for about 3 minutes then a slow blue. I was thinking "that was easy", but when I mount the device the update file is still in the root and the version.txt still has the old version number. I then tried the "bunnyupdater" again everything looked like it was working for about 3 minutes, but same results. I have even tried the "3* green led wait then pull" reset, but both give same results. Everything else seems to be working. I can connect to it over serial with screen, create a payload that works, ssh to it, setup networking and ping google from it. It is great, but I cant update it. I have to be missing something stupid simple. Please help.

Link to comment
Share on other sites

So I think I figured this out and thought I would give an update so if anyone else runs into this issue they have one more thing to check. When I was troubleshooting I used multiple computers and even did the ase256 check when the update file was on the BB and it was good. I also tried going to version 1.4 with the same issue. I swapped everything out BUT the usb c adapter is was using. When I eliminated the adapter and plugged directly into a computer it worked. The issue seems to be the apple usb adapter Model: MJ1M2AM/A 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...