Jump to content

Nano Tactical Battery doesn't work??


Kento
 Share

Recommended Posts

Hello, I just got my Wifi Pineapple Nano Tactical kit yesterday and the battery it came with doesn't turn the Pineapple on. I plugged the power bank in over night and this morning when I checked, it had 3 little dots to show it was charged, so I plugged in my Pineapple and it didn't turn on, so I tried clicking the little button on top which did absolutely nothing (not even turning on the lights 0_o), so I tried to plug in my phone and it didn't charge that either. I then tried to charge the power bank again, but when I plugged it in, it showed 3 dots, and when I clicked the button on top, it would turn on the lights again... I let it sit plugged in for a few more hours and tried it again with multiple devices and nothing worked..

Am I using this power bank wrong or is it faulty??? I also tried multiple clicks of the button, long clicks, short clicks, and multiple long clicks and nothing worked :(

 

Any help is greatly appreciated! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...