Jump to content

bashbunny update system time and getting autosploit working


sajansen
 Share

Recommended Posts

Hey,

 

I'm trieing to get autosploit working on the bashbunny. For now im trieing to install the needed ruby version. From what i found, the best way to do this was using "rbenv install 2.5.1" but i ran into some problems:

First off, the time/date on the bunny is 2014 when it boots and so i need to wait for it to update the time before i can start the install command as i cant verrify the ssl certificate with a wrong time. so help with forcing a time update would be great.

My second problem is that the bunny gets rather hot when installing ruby, most of the times it stops do to overheating. For now my solution is to put the bunny in teh fridge for a while XD - yea, dont ask - is there something like CUCUMBER ENABLE or something that can help when using ssh to run the commands as it still seems to use all 4 cores.

then after that ive not been able to install: gem "install rex-mime"  as it complaned that the ruby version was wrong.

 

Well for now im still trying to install the ruby version (had to put the bunny in recovery mode to fix some problems i had with ruby and stuff being roially fucked up. So long story short, is there a good way to get autosploit working? for now ive just been doing it to stupid way: 1. run 2. fix errors 3. goto step 1

 

If anyone can help me that would be great :) I have no experiance with arm systems... a lot less is avalible resource whise.

PS. sorry for spelling mistakes and stupid questions, its 2 AM and the last few days have been late ones, trieing to fix this.

Link to comment
Share on other sites

It turned out i installed/setup things in the wrong order. at least i have the right ruby version running now. and for some reason CUCUMBER ENABLE seems to be working after a couple reboots of the stick. I'm probably not going to finish this today so after the installations of bundle is done im going to call it quits for today. further tips and advice is walcome, ill be picking this up around sunday or so.

Link to comment
Share on other sites

autosploit is not easy to setup and very time consuming if you have never messed with it.  Took me a couple days and editing the payload to get it fully working on my bashbunny.

Link to comment
Share on other sites

I noticed... i have a basic understanding of linux in general... now im documenting what im doung and resetting when it goes wrong... so far i got metasploit running once but without database support.

 

after a reset now im having some random problems installing ruby. Sometimes i get a out of menory and the next time its a random other error. Indeed, this takes time but its fun to mess around with.

 

luckely its verry easy to reset the bunny when i mess up ? that is what i call a good learning platform

 

when i pick it up again, ill trie and add the documentation, maybe im doong stuff the hard way?

Link to comment
Share on other sites

I seem to have ruby setup now. not sure if its fully working but it seems to so far.

Now i have some problems with teh database. it sees it but complains about "warning: na database support: no database YAML file"

and when i do: db_connect postgres, i get: error while running command db_connect to the database: fatal: role "root" does not exist

I also get the same massage when i run psql. Seems like the user root isnt there or something but i have no clue how to check what the problem is.

 

Also on a second note: is it correct dat top and htop show no swap partition on the bunny? i ran into soem memory problems earlyer. i can remember a post from Darren saying that it should have around ~1  GB of swap?

Edited by sajansen
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...