Jump to content
Sign in to follow this  
sebaz

PineAP settings location

Recommended Posts

Hi all!

 

Is there a default location for the pineap settings? I'm trying to make it so that the settings stay saved even when you reboot the device. Thanks in advance!

 

Regards,

Sebastiaan

Share this post


Link to post
Share on other sites

PineAP settings are stored like any other module onboard the pineapple.

To make your configuration static across all boots:

  1. ssh root@172.16.42.1
     
  2. cd /pineapple/modules/PineAP/js
     
  3.  Modify module.js block for 'PineAPSettingsController'
registerController('PineAPSettingsController', ['$api', '$scope', '$timeout', function($api, $scope, $timeout) {
    $scope.disableInputs = true;
    $scope.disableButton = false;
    $scope.saveAlert = false;
    $scope.pineAPenabling = false;
    $scope.settings = {
        allowAssociations: false,
        logEvents: false,
        pineAPDaemon: false,
        beaconResponses: false,
        captureSSIDs: false,
        broadcastSSIDs: false,
        broadcastInterval: 'low',
        responseInterval: 'low',
        sourceMAC: '00:00:00:00:00:00',
        targetMAC: 'FF:FF:FF:FF:FF:FF'
    };

Heres an example of some configurations stored here. 

 

Share this post


Link to post
Share on other sites

However,

When I change these settings, they don't stay 'saved'

The checkboxes load as 'checked' but then get unchecked as the page loads further.

 

Quote

registerController('PineAPSettingsController', ['$api', '$scope', '$timeout', function($api, $scope, $timeout) {
    $scope.disableInputs = true;
    $scope.disableButton = false;
    $scope.saveAlert = false;
    $scope.pineAPenabling = true;
    $scope.settings = {
        allowAssociations: false,
        logEvents: true,
        pineAPDaemon: true,
        beaconResponses: false,
        captureSSIDs: true,
        broadcastSSIDs: false,
        broadcastInterval: 'low',
        responseInterval: 'low',
        sourceMAC: '00:00:00:00:00:00',
        targetMAC: 'FF:FF:FF:FF:FF:FF'
    };

 

Edited by sebaz

Share this post


Link to post
Share on other sites
7 minutes ago, sebaz said:

When I change these settings, they don't stay 'saved'

In the latest RC1 test firmware (i have currently installed) the settings are saved over reboots/power downs - they are stored in  /etc/config/pineap

Edited by Just_a_User

Share this post


Link to post
Share on other sites

Cool! Now the daemon starts properly, and the 'capture SSIDs to Pool' checkbox stays checked. However, the 'log Pineap events' checkbox stays unchecked..

Share this post


Link to post
Share on other sites
9 minutes ago, sebaz said:

 However, the 'log Pineap events' checkbox stays unchecked..

For me on TETRA that box state remains over reboot/power cycle. Do you click the "Save PineAP Settings" button each time you change anything?

Share this post


Link to post
Share on other sites
4 minutes ago, sebaz said:

I do, but it doesn't. Im on the nano but latest firmware (2.02)

OK im using the 2.1.0 RC1

Share this post


Link to post
Share on other sites

Well.. now my API calls stopped working. Do you have any idea if the update changed something with the api for the logging and client modules? Sending notifications still works, so it isn't my api key or syntax as far as I can see

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...