Jump to content

Shell (via. PuTTY) "dir" and "ls" listing issues?


DelTex
 Share

Recommended Posts

Maybe I'm wrong, and tell me if I am because there's a good chance that I don't know what I'm talking about.

But, "ls" which should by default list the information about the files in your current directory, only shows "udisk" and "version.txt".

So naturally the next command I used was "ls -a" which should show all items in your current directory (all these commands are being entered from root just to be clear). I expected then to see all the files I see when I plug my BB in switched to arming mode (i.e. loot, payloads, tools, docs, languages, versions, config, bunnyupdater, a few .exe and extra .txt files I have in there, etc...)

This is not what I saw, instead I saw things like ".bash_history" and ".bashrc". Not what I expected, but again I'm learning here so maybe everything is as it should be?

I tried the same things with "dir" and "dir -a" and received the same results.

However, when I typed "cd /tools" it threw me into "root@bunny:/tools#"... "/tools" didn't show up in any of my previously entered requests to list what was in the current "dir"... So I'm confused... I even tried some special requests that specify the listing of items that contain "/"'s in them. Nothing.

If you have any idea here on what I should do, your explanation would be much appreciated. Please explain your answer if you don't mind though, I'm trying to understand and learn here and not just copy and paste text. Thanks!

 

(Below is a picture of my input and the output I got while being SSH'ed into my BB via. PuTTY using the COM connection type, thanks again)

 

1.png

Link to comment
Share on other sites

Ahh, new to Linux and SSH?

When you first SSH in you end up in the root user folder which is /root or "~/"

If you notice your prompt for our first few commands it has "~#" proceeding it.  You are in the root's home folder there or the current user's home folder which is root.  After your "cd /tools" you may notice that prompt changed to "/tools#".  You are in the tools folder off of the root folder..not root home folder.

If you type "cd /" and do a ls you will see everything install on the root partition of the bunny.

Pretty much when you SSH in, do not expect to see what you see when you are in arming mode on the bunny and browsing it like a USB stick.  That is a mounted partition, not the root.  You will also notice the udisk folder is empty.  It is not mounted yet to view it.  "udisk mount" will mount it and then you can view it under /root/udisk or "~/udisk" which will show your loot, payloads, etc folders.

The main root partition is the system files for the bunny, mess up those and bunny no workie at all.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...