Jump to content

Management AP through Ethernet/router on linux


Recommended Posts

Hello !

First I'd like to say my experience with tetra has been pretty amazing. The radio on this thing is amazing! Nothing compares in that area.  

Anyway, the problem I'm having is connecting to management interface via Ethernet. The pineapple is able to connect to the internet just fine but I am unable to connect to the management interface through Ethernet. No issues through wifi or through usb port with my phone. It blows my mind I can connect through the USB port but not Ethernet!!

 

I read a few post and it said it's supposed to be as easy as connecting to the assigned IP my router assigns my pineapple. In this case my router assigned 192.168.1.23. I assumed I would just connect using 192.168.1.23:1471 using firefox. As I did connecting via WiFi using 172 range. 

Is there something special I must do to connect to the pineapple interface via Ethernet?

Link to comment
Share on other sites

Yes you have to set firewall rules and network settings.  If you search the forums on the nano you can find it, if you don't Ill post it later today.

Link to comment
Share on other sites

 

Add these to /etc/config/firewall, save, reboot pineapple.  Your not suppose to be able to access the webui or ssh via the ethernet cable for security reasons.

config rule
        option name 'Allow-WebUI'
        option src 'wan'
        option proto 'tcp'
        option dest_port '1471'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-SSH'
        option src 'wan'
        option proto 'tcp'
        option dest_port '22'
        option target 'ACCEPT'
        option family 'ipv4'

 

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

THANK YOU worked perfect. 

I understand. But until figure out which modules use which radios I get tired of walking over there and plugging in my phone. Also I want to use a 3rd USB wifi adapter -  I am sure I am going to mess things up along the way. 

My goal here is have a USB wifi adapter dedicated just to connection ssh and gui. Then I wont need to use Ethernet anymore. Nor will I have to worry about not being able to connect. 

 

Thanks again!

Link to comment
Share on other sites

  • 2 weeks later...

I attach (rubber band style) a small GL-AR300M travel router and connect a tetra via eth0, disable wlan0-1 (speeds things up) and connect to the tetra without changing any of the firewall.

e.g. https://192.168.8.100:1471

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...