Jump to content

Recommended Posts

Hey guys,

I recently received my HackRF One after having experimented with an RTL-SDR USB Dongle in the SDR# software. I first set up Pentoo Linux and tried out GNU Radio Companion as suggested by Mike Ossmann himself. However I was a little discouraged when I found out that some things had changed in GNU Radio Companion since the making of his tutorials and "blocks" that he made use of are missing in the newer versions of GNU Radio Companion. Today I tried to use the HackRF with the SDR# software. I had been using it very easily with my RTL-SDR previously, and I used "Zadig" to install the WinUSB (v6.x.xxx.xxxxx) driver for the HackRF One. I started up SDR#, selected HackRF One as the input device and started the capturing. I got a lifeless waterfall diagram with fixed "spikes". When I set the tuner to a specific frequency where I know there is a radio station transmitting I can't see anything but jibberish of very small constant amplitude. (apart from those few fixed spikes)

This is definitely not due to my location/bad reception as from the same location using the same antenna the much cheaper RTL-SDR captures good quality FM Radio. So far all I've found out is that those static "spikes" are probably because of the DC power related to the HackRF. Tried messing with LNA Gain and different Demodulation Techniques. Other than that I am clueless. Am I missing some step in setting the HackRF up? Any ideas as to why this is happening? In Pentoo, "hackrf info" command works. Is there some other way to find out if I have a defective unit? 

Any help is greatly appreciated.



Link to comment
Share on other sites

Some common issues when using Windows is driver problems.  Sometimes you have to completely uninstall the driver and then reinstall for it to work. I would try base settings as well.  You want to also pay very close attention to which device you select from the list.  It should be called "hackrf" or "bulk-in interface X".  

On the Linux issue, did you follow the git guide on how to check if the HackRF is detected?  https://github.com/mossmann/hackrf/wiki/Getting-Started-with-HackRF-and-GNU-Radio  I would verify that the radio is being seen by the os as a first step to finding a solution.   This info can be found in the "Examples" section of the link. 


If any on the steps above don't get you HackRF working, be sure to take screenshots to help further diagnose the problems!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...