Jump to content

PineAP clients cannot get access to the internet


Recommended Posts

Hi guys,

When I share internet from Pineapple, clients are able join to my PineAP, but cannot get access to the internet. There is an error message "error connection refused" in browser. When I connect to PineAP with my Android phone, i can search anything from Google on Chrome browser, but when i go to actual website, it shows me that cannot connect to the Internet (error connection refused). Other browsers and apps also cannot connect to the Internet.

Could someone help me to solve this

Link to comment
Share on other sites

Is the Android phone your using to connect to the PineAP also the Android phone your using to host a hotspot over data (3G/4G or whatever)? If so, the Android phone was probably just using it's data to browse Google, while WiFi was connected to the PineAP but wasn't using it because it detected it didn't have network over WiFi.

How are you sharing your Android phone's data with the PineAP? Check here: https://wifipineapple.github.io/wifipineapple-wiki//#!./connectivity.md#USB_Tethering_(Android)
NOTE: There's also an app that does this for you here: https://play.google.com/store/apps/details?id=org.hak5.pineappleconnector

Also, just as a side note, the PineAP was built for people who already knew a lot about WiFi and networking, and by the sounds of your post you don't know an overly large amount about either of those (not to mention Android phones and browsers..). I'm not saying this to be mean or take jabs at you or anything like that, I'm just saying that you're putting yourself in the deep end.

Link to comment
Share on other sites

Thanks for reply,

I solved this problem by editing wp5.sh script. I removed state in iptables rules, then it worked.

It was:

       iptables -A FORWARD -i $pineapplewan -o $pineapplelan -s $pineapplenet -m state --state NEW -j ACCEPT
       iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
       iptables -A POSTROUTING -t nat -j MASQUERADE

       iptables -A FORWARD -i $pineapplewan -o $pineapplelan -s $pineapplenet -j ACCEPT
       iptables -A FORWARD -j ACCEPT
       iptables -A POSTROUTING -t nat -j MASQUERADE

BTW,  I was sharing from 3G modem, Android phone is just clinet.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...