Jump to content
amadeuspzs

Solved: USB Tethering of Verizon Jetpack AC791L

Recommended Posts

Hello folks,

In response to my attempts to USB tether a Verizon MiFi jetpack to the Nano (TL;DR - it won't work):

I have switched to the Verizon Jetpack AC791L (https://www.verizonwireless.com/internet-devices/verizon-jetpack-4g-lte-mobile-hotspot-ac791l/) instead, which does not work out of the box but can be fixed pretty easily:

First off, make sure when you connect the device you enable USB Tethering through the on-screen prompt. Then you should see:

root@Pineapple:~# lsusb
Bus 001 Device 005: ID 0846:68e1 NetGear, Inc.
Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc.
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and

root@Pineapple:~# lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=ath9k_htc, 480M
        |__ Port 2: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 3: Dev 5, If 0, Class=Wireless, Driver=rndis_host, 480M
        |__ Port 3: Dev 5, If 1, Class=CDC Data, Driver=rndis_host, 480M

Now, the device will be listed as `eth1` which won't be enabled:

root@Pineapple:~# ifconfig -a
br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:91:AD:EA
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1340 errors:0 dropped:35 overruns:0 frame:0
          TX packets:1515 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:227079 (221.7 KiB)  TX bytes:1175120 (1.1 MiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:91:AD:EA
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1355 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1519 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:248623 (242.7 KiB)  TX bytes:1175304 (1.1 MiB)
          Interrupt:4

eth1      Link encap:Ethernet  HWaddr 00:A0:C6:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:164 errors:0 dropped:0 overruns:0 frame:0
          TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11650 (11.3 KiB)  TX bytes:11650 (11.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:91:7F:19
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:212 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:24826 (24.2 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:C0:CA:91:7F:19
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:206 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:23207 (22.6 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:C0:CA:91:96:32
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

You need to set this device up to receive an IP address via DHCP.

In /etc/config/network add:

config interface 'jetpack'
	option ifname 'eth1'
	option proto 'dhcp'
	option dns '8.8.8.8, 8.8.4.4'

Restart, and you should be good to go ?.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...